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I. Introduction 

This manual document describes the tool IC-EMC (acronym for Integrated Circuit 
Electromagnetic Compatibility) which aims at simulating parasitic emission and susceptibility 
of integrated circuits and eases the comparison with measurements. The tool uses the 
simulators WinSpice, Ngspice and LTSPICE® for SPICE simulation. The software can be 
downloaded on www.ic-emc.org.  

IC-EMC is a free simulation software entirely dedicated to the EMC of ICs issues. IC-EMC is 
not geared to full-chip simulation coupled with a 3D electromagnetic solver and is not 
intended to address complex EM problems. It aims at developing simple models of ICs and 
its surrounding environment (IC package, PCB traces, cables) for simulation of emission, 
susceptibility and signal integrity. Its purpose is twofold:  

Á help the user to develop EMC models rapidly for an efficient evaluation of EMC 
performances 

Á illustrate EMC issues related to ICs for educational purpose of basic notions and 
modelling techniques related to EMC 

To obtain more accuracy or to address more complex problems, we advise you to use the 
professional CAD tools available in your university, lab or company 

 

This manual is organized as follows: 

Á The second section (Getting started) presents an overview of the software and 
describe how to install and launch it 

Á The third section (Working with IC-EMC) shows the different possibilities of the 
software through several practical examples 

Á The fourth section (Description of the menu) describes the different menus of the 
software 

Á The fifth section (Description of the symbols) lists all the symbols proposed by the 
software to build electrical schematic diagram 

Á The sixth section (Input/output file format) describes the different exchange files used 
by the software   

 

The authors have dedicated around ten years to build the technical contents of this manual 
and software, and tried their best to improve the IC-EMC tool, trying to keep the usage 
simple. As the tool is in constant evolution, we encourage the reader to download the 
updated version of IC-EMC form the web page and we would appreciate feedback and 
comments. 
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II. Getting started with IC-EMC 

IC-EMC is a simulation software entirely dedicated to the EMC of ICs issues. It works only 
with Windows Vista and Windows 7 or 10. IC-EMC is a schematic editor interfaced with three 
free SPICE simulators: WinSPICE, Ngspice and LTSPICE. By exploiting simulation results 
provided by these simulators, IC-EMC proposes a set of post-processing tools to extract 
relevant EMC information. The section aims at presenting an overview of the software and 
how to install and launch it. 

 

II.1 Overview of the software 

The tool IC-EMC is able to perform comparisons between measurements and simulation of 
conducted, radiated emission, near-field emission, S and Z parameters, immunity and signal 
integrity, as illustrated in Figure 2- 1. Moreover, it includes also different tools to build models 
of IC package, PCB traces and cables.  

Package viewer & modeling

IC-EMC

IBIS file editor Susceptibility simulation

Near field emission simulation

Emission simulation
Z/S parameter simulation

Signal integrity simulation
PCB/cable modeling

 

Figure 2- 1: Main features of IC-EMC 

 

The main commands of IC-EMC are shown in Figure 2- 2. From left to right, the Spice 
Simulation icon translates the schematic diagram into a SPICE compatible text file, the next 
icons give access to the emission spectrum window, the impedance vs. frequency, the 
immunity simulation screen, and the near-field simulation screen. 
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Near-field 

simulation
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Spice 

simulation

Spectrum 

analysis

Immunity 

simulation

Impedance 

simulation

S parameter 

simulation

Ibis file 

editor
Import 

Library
Parametric 

analysis

 

Figure 2- 2: Main commands proposed by -EMC 

 

Figure 2- 3 describes the general simulation flow with IC-EMC. The process starts with the 
edition of the circuit schematic. Component models are provided by IC-EMC or external 
libraries. The netlist file generated by IC-EMC serves as input file for the SPICE simulator 
(WinSPICE, Ngspice or LTSPICE). At the end of the simulation, SPICE simulation results are 
exploited by IC-EMC post-processing tools. Different measurement file formats can be 
imported to compare simulation and measurement results and tune simulation models.  

IC-EMC schematic 
editor (.sch) Model libraries

WinSPICE/ LTSPICE / Ngspice-
compatible netlist generation (.cir 

/ .raw)

WinSPICE/ LTSPICE / Ngspice
simulation

IC-EMC post-processing tools 
(emission, impedance, S-
ǇŀǊŀƳŜǘŜǊǎΣ ƛƳƳǳƴƛǘȅ Χύ

Importing of 
measurement result 

files

Output file generation
 

Figure 2- 3: General simulation flow with IC-EMC 

 

 

II.2 Installing and running IC-EMC 

The following paragraphs detail the different steps for installing, running and exiting the 
software.  

II.2.1 Download the Schematic Editor 

The software can be downloaded from www.ic-emc.org. The zip file contains an executable 
file (icemc.exe) and folders containing libraries and examples. 
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After downloading and unzipping 
the IC-EMC software package, a 
main directory called ñIC-EMC-2v9ò 
is displayed. This directory 
contains a list of subdirectories 
organised as shown in Figure 2- 4.  

It contains the IC-EMC executable 
file (ic_emc.exe) and a further 
collection of subdirectories. Some 
of them contain examples and 
case studies, while others contain 
component libraries. Their content 
is briefly described in Table 2- 1. 

 

 

Figure 2- 4: Organisation of the main 
directory IC-EMC-2V9 

 
Subdirectory name Contents 

book The subdirectory contains the schematic 
diagrams and measurement results presented 
in the book: A. Boyer, E. Sicard, "Basis of 
Electromagnetic Compatibility of Integrated 
Circuits", Collection Pour l'Ingénieur, Presses 
Universitaires du Midi, 2017. 

case_study The subdirectory contains schematic diagrams 
and measurement results related to several 
case studies described on the website www.ic-
emc.org 

examples The subdirectory contains various schematic 
diagram related to basic notions of EMC, 
emission, near-field, susceptibility... 

help HTML pages of online help 

ieee Symbol library used by IC-EMC (*.sym). Some 
are available from the palette (see 11.2.7), 
while others can be downloaded by clicking on 
ñInsert Ą User Symbol (.SYM)ò. 

lib .tec file and default non-linear device SPICE 
library (.lib) (e.g. a diode, BJT, CMOS 
transistor, non-linear capacitor, switch) 

Table 2- 1:  Content of the subdirectories of the main directory IC-EMC-2v9 

 

II.2.2 Download WinSPICE 

The WinSPICE analogue simulation tool may be downloaded from www.winspice.co.uk. 

Click on the  icon to run the WinSPICE solver wspice3.exe. It is necessary to define in 
IC-EMC the access path of the solver wspice3 (see II.2.6). 
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II.2.3 Download LTSPICE 

The LTSPICE free simulation tool (LTSPICE XVII) may be downloaded from 
https://www.analog.com/en/design-center/design-tools-and-calculators/ltspice-simulator.html. 

Click on the  icon to run the LTSPICE XVII solver XVIIx64.exe. It is necessary to define 
in IC-EMC the access path of the solver XVIIx64 (see II.2.6). 

 

II.2.4 Download Ngspice 

The Ngspice free simulation tool may be downloaded from http://ngspice.sourceforge.net/. 

Click on the  icon to run the solver ngspice.exe. It is necessary to define in IC-EMC the 
access path of the solver Ngspice (see II.2.6). 

 

 

II.2.5 Initial Screen 

To launch IC-EMC, double-click on executable file ic_emc.exe  in the main directory of 
IC-EMC. The following figure presents the interface when the software opens. The editor 
contains a palette of symbols (Window "Symbols" situated on the right of the screen) and 
some basic editing icons to build the schematic diagram of the circuit and control the main 
EMC screens. 

Menus Command bar

Welcome 

message

Symbol palette

Editing interface of schematic diagram

Selected technologyMessage bar

Name of the current 

schematic

 

Figure 2- 5: IC-EMC user interface  

The symbol palette gives access to the most common elements of electrical schematics, 
such as passive devices, voltage and current sources, transmission lines and interconnects, 
measurement probes for voltage, current, impedance, power, S-parameters etc., in addition 
to diodes, MOS devices, bipolar junction transistors and input/output buffer models extracted 
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from an IBIS file. The components of the symbol palette are described in Erreur ! Source du 
renvoi introuvable.. The palette is visible as soon as IC-EMC is run. If the palette is closed 

accidentally, it can be reopened by clicking on "View > Symbol Palette" or clicking on the  
icon in the command bar. 

All the components placed on schematic diagrams are described in a .sym file, which 
describes both the graphical aspect of the component in the schematic and the SPICE model 
of the component. Not all the components supported by IC-EMC are in the symbol palette. 
IC-EMC proposes additional components that can be inserted in the schematic through the 
Insert / User Symbol (.SYM) command. They can be either constructed by the user as a 
SPICE subcircuit (using command "File > Generate SPICE Subcircuit"), or found in the list of 
symbols in the "ieee" subdirectory. More information about the symbols contained in the 
system/ieee directory can be found on the IC-EMC companion website.  

R, L and C

Mutual inductance

Diode

Ideal transmission 

line
(Radiated) interconnect

Bidirectional coupler

Voltage and current 

sources

RF generator for 

susceptibility simu.

Ground and VDDref. Voltage-controlled voltage source

Non-linear V/I source

Voltage and current 

probes
Set initial voltage 

condition on a node
Z(f) probe

Eye diagramPort for S parameter 

simu. Diff. / Common-mode 

voltage probe
NMOS/PMOS devices

Inverter

NPN/PNP BJT IBIS single-

ended/diff. 

driver/receiverI/O pin (for subcircuit 

generation)

Electrical arrow 

(connection to a node)

Box & Info. symbol

HF models of R, L or C

Voltage-controlled 

current source

Voltage-controlled switch

 

Figure 2- 6: Symbol palette 

 

The main commands for EMC and post-processing can be found in the EMC menu or the 
command bar, as shown in Figure 2- 7. After editing the schematic and setting the simulation 
parameters, click on the 'Generate SPICE netlist' button to translate the schematic diagram 
into a SPICE-compatible text file. This step is necessary before any new SPICE simulation or 
post-processing of results. The following icons give access to the main post-processing tools 
(e.g. emission window, near-field simulation, immunity simulation, Z- and S-parameters etc.). 
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simulation
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simulation

Spectrum 

analysis

Immunity 

simulation

Impedance 

simulation
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simulation

Ibis file 

editor
Import 

Library
Parametric 

analysis

 

Figure 2- 7: Main simulation commands 

II.2.6 Configure simulator options 

Before launching SPICE simulations, it is necessary to define the access path of the 
simulators (WinSPICE, Ngspice and LTSPICE) and the launching options. It can be 
configured by clicking on the command menu "File > Simulator > Configurations". The 
following window opens. 

 

Figure 2- 8: Simulator configurations (File > Simulator > Configurations") 

Set the access path of WinSPICE, LTSPICE and Ngspice simulator executable files in the 

fields "WinSPICE", "LTSPICE" and "Ngspice" by clicking on the button . This operation 
has to be done manually each time the user reinstalls SPICE simulators and their installation 
directories. In the lower part of the screen, three simulation options are proposed: 

Á Launch simulator manually: when the user generates SPICE netlist , he has to launch the 

simulator, opens the circuit netlist (.cir file) and launch the simulation 

Á Interactive mode: when the user generates SPICE netlist , the simulator is automatically 

launched and remains opened at the end of the simulation to analyze the result 

Á Batch mode: when the user generates SPICE netlist , the simulator is automatically 

launched but is closed directly at the end of the simulation 
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II.3 Using IC-EMC 

II.3.1 Create my first model 

As first simple example, we consider a resistive voltage divider excited by a sine waveform 
signal at its input. The divider is made of two resistance of 1 Kɋ. The amplitude of the signal 
is 1 V and its frequency is set to 100 MHz. The simulation aims at predicting the transient 
waveform of the voltage at the output of the resistive divider. 

Double-click on executable file ic_emc.exe  to launch the software. if it is already opened, 
click on the command "File > New" or "CTRL+N" to create a new schematic diagram. 

Pick two resistor symbols  in the Symbol palette, drag and place them on the schematic. 
These symbols are called R1 and R2 by default. Their default resistance is 50 ɋ. Click on the 

icon to rotate to the right the resistor R2. The result is shown in Figure 2- 9. To change 
the properties of the symbols (name and resistance), double-click on the symbol. The 
window shown in Figure 2- 10 opens. Change the resistance value of both resistors to 1 K in 
the field "Value". To change the name of a symbol, write the new name in the field "User 
name". To validate the change, click on the button OK or type "Enter" key. 

 

Figure 2- 9: Place two symbols of  resistor on a schematic diagram 

 

Figure 2- 10: Change the resistance value of a resistor symbol 

Then, pick the voltage source symbol  in the Symbol palette and place it on the schematic 
diagram on the left of R1 (Figure 2- 11).  



 II. Getting started with IC-EMC 

 

19 

 

 

Figure 2- 11: Place one voltage source symbol on a schematic diagram 

 

Double-click on the voltage source symbol to edit its properties. Click on the tab "Sine 
Parameters" to set a sine waveform generator. The following parameters are proposed: 

Á VO: offset voltage (V) 

Á VA: amplitude of the sine waveform (V) 

Á Freq: frequency (MHz) 

Á TD: delay (ns) 

Á Theta: damping factor (1/s) 

Use the parameters shown in Figure 2- 12 and click on the button OK 

 

Figure 2- 12: Edit the properties of a  voltage source  

 

All the electrical components of the circuit have been placed. Now, they have to be 
interconnected. Interconnections between symbol's nodes are ensured by wires. To add 
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wire, click on the icon "Line"  or on the menu "Edit > Line". Line edition mode is activated 
and wires are created between two points selected on the schematic with the left button of 

the mouse. The line edition mode is deactivated by clicking on the icon "Select"  or hitting 
the ESC key. Alternatively, line edition mode can be activated by clicking on the schematic 
with the left button of the mouse. Place wire between the different terminals of the symbols. 

Terminals are highlighted by square symbol . The result is shown in Figure 2- 13. Before 
simulation, it is necessary to indicate the voltages and currents that we want to observe by 

placing voltage  and current probes  on the schematic diagram. Voltage probes are 
connected on one node of the diagram while current probe are placed within one circuit 
branch. In this example, place two voltage probes: one at the divider input (between V1 and 
R1), the other at the divider output (between R1 and R2). 

 

Figure 2- 13: Place wire to interconnect the different symbols of the schematic diagram  

 

The schematic diagram is nearly terminated, but an important element has been forgotten. In 
any SPICE netlist, a '0' or reference node has to be defined. Forgotting such reference node 

will result in simulator error. Place the symbol "Ground"  on the schematic, between V1 
and R2. The final schematic diagram is shown in Figure 2- 14. 
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Figure 2- 14: Place voltage probes and the ground symbol  

 

Before launching the SPICE simulation, IC-EMC converts the schematic diagram into a 
netlist (file .cir) compatible with WinSPICE, Ngspice or LTSPICE. This netlist describes the 
circuit in components whose terminals are referenced by number. Each number indicates a 
node of the schematic diagram. All the terminal with the same node number are connected 
electrically. To see the number of the different nodes forming the schematic diagram, click on 

the icon  or on the menu "View > View Electrical Net" (Figure 2- 15). Voltage probes have 
been placed on nodes 1 and 2. This view can be convenient to verify electrical connections 
between the symbols during debug.  

 

Figure 2- 15: View the nodes of the schematic diagram (icon  ) 
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II.3.2 Save the schematic diagram 

Before launching any simulation, it is extremely important to save the schematic in a known 

directory. Click on "File > Save as" or on the icon  or CTRL+S to save the schematic 
diagram. They are saved in .sch file. Save it as Voltage_Divider.sch. The final version of this 
schematic diagram is available in the directory "\examples\basic\FFT". 

II.3.3 Prepare the analysis 

SPICE simulator proposes different analyses (DC, AC, TRAN...). The analysis is defined and 
configured by a analysis command line added to the schematic. Here, we want to set a 
transient simulation. The most convenient way to set simulation parameters for beginners is 
to click on "Insert > Insert analysis line". The following window open to set up the SPICE 
analysis. Select the tab "Transient analysis" and set: 

Á Stop time: 100 ns 

Á Step time: 0.1 ns 

The SPICE analysis command line appears at the bottom of the window and is updated each 
time the analysis parameters are changed. The format of the analysis line is also shown. 
Finally, click on the button "Insert" and click "Close". The analysis line is automatically 
inserted on the schematic diagram, as shown in Figure 2- 17. Alternatively, the analysis line 

can be directly added on the schematic by clicking on the icon  and type the command line 
".tran 0.1n 100n". 
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Figure 2- 16: Define the SPICE analysis 

 

Figure 2- 17: Insert the SPICE analysis line on the schematic diagram 

II.3.4 Launch my first simulation 

Before launching your first simulation, you should ensure that the access paths of the 
simulators have been defined as explained in part II.2.5. Two SPICE simulators are 
supported by IC-EMC: WinSPICE, Ngspice and LTSPICE. To select a simulator, click on the 
menu "File > Simulator" and select "WinSPICE", "Ngspice" or "LTSPICE". In this example, 
WinSPICE will be used. Click on the menu "File > Simulator > Configurations" and select the 
option "Interactive mode": the simulator will be launched automatically when the netlist will be 
generated. 

Click on the button  or on the menu "EMC > Generate SPICE file" or hit CTRL+G to 
launch the simulation. Actually, this command is twofold: 

Á the electrical schematic diagram is converted in a netlist, saved in a .cir file. The netlist file has 

the same name than the schematic file (Voltage_Divider.cir). The window shown in Figure 2- 

18 appears when the netlist file is generated to verify the content of the netlist. Click on the 

button "OK" to close this window. 

Á in "File > Simulator > Configurations", if the options "Interactive mode" or "Batch mode" 

have been selected, then the SPICE simulation is automatically launched. If the option 

"Launch simulator manually" is selected, then the user has to launch the simulator and select 

the .cir file. 
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Figure 2- 18: Generation of the netlist file 

SPICE simulation is launched automatically and the WinSPICE interface opens. At the end of 
the simulation, the message "Simulation Completed" is displayed on the WinSPICE interface 
and the simulation result is displayed (Figure 2- 19). IC-EMC proposes tools to analyze 
simulation results, as described in the next part and the next chapter of this manual. 

 

Figure 2- 19: WinSPICE simulation launching and result 

 

II.3.5 Analysis result 

First, the transient waveforms of input and output signals are analyzed. Open the "Voltage 

vs. Time" window by clicking on the button  or on the menu "EMC > Voltage vs. Time", 
presented in Figure 2- 20. The signals associated to the voltage probes added on the 
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schematic diagram appears on the list "Signal" in the top-right part of the window. Select both 
signals (v(1) and v(2)) and click on the button "Add Simu" to plot them.  

 

Figure 2- 20: Time -domain analysis with IC-EMC ("EMC > Voltage vs. Time") 

 

In the tab "Display", different options are proposed to change the axes settings. Amplitude 
and period characteristics can be extracted by clicking directly on the graph. More indicators 
are available in this tool. They will be described in the next chapters. A practical example is 
shown in III.6. Close the window by clicking on the button "Close". 

Then, the spectrum of the input signal is analyzed. Click on the icon  or on the menu 
"EMC > Emission vs. Frequency". The window shown in Figure 2- 21 opens, showing the 
spectrum of the input and output signals of the voltage divider. The spectrum is computed by 
Fast Fourier Transform (FFT). The number of points can be changed to adjust the resolution 
by clicking on the list "Resolution" in the tab "FFT Parameters". Select 4096 points and a 

Blackman window. In the tab "Display", click on the button  in the tab "Display" to set a 
logarithmic scale on Y axis. The voltages are expressed in dBµV, which is typical in 
conducted emission measurement. 

The FFT result presents a large peak centered at 100 MHz. Its amplitude is equal to 120 
dBµV, i.e. 1 V. This result is consistent with the sine wave nature of the signal. Click on the 
button "Close" to close this window. 
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Figure 2- 21: Frequency -domain analysis with IC-EMC ("EMC > Emission vs. Frequency") 

 

II.3.6 Close IC-EMC 

Before leaving IC-EMC, save your schematic diagram by clicking on the icon  or click on 
the menu "File > Save". Click "File > Exit IC-EMC" or hit CTRL+Q to close the software. 
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III. Working with IC-EMC 

This part provides straightforward examples of how to use IC-EMC to create simple model of 
a circuit and perform the main analysis proposed by IC-EMC:  

Á simulation of electromagnetic emission based on the transient response of voltage or current 

Á simulation of impedance and S parameters of passive or active devices, PCB traces, cables... 

Á simulation of the conducted immunity of IC to harmonic disturbance 

Á analysis of IBIS file and extraction of equivalent models of I/O buffers 

Á analysis of transient signals (timing characteristics, statistical properties, short-term FFT) 

Á simulation of signal integrity and eye diagram plot 

Á simulation of near-field emission based on thin-wire approximation 

Á modelling of various type of interconnects (PCB traces, cables, IC package, power-ground 

plane pair) 

Á estimation of IC emission model 

 

IC-EMC is also able to import measurement files to compare simulation with measurement 
results. 

III.1 Simulation of the conducted emission of a microcontroller 

This example presents the flow to simulate the conducted emission of a microcontroller, 
using a simplified microcontroller model. Simulated conducted emission measurements are 
related to the IEC 61967-4 standardôs 1/150 ɋ method [IEC61-4]. 

III.1.1 Open the example 

Open file "examples\emission\mpc\mpc_vde.sch" (Figure 3- 1). The model includes a 
description of the microcontroller based on a set of RLC elements and a current source, 
according to the IEC62433-2 ICEM-CE model format [ICEM]. ICEM is an IEC standard 
dedicated to emission modelling. Moreover, resistances RVDE, R49 and RSA are added as an 
equivalent model of the current measurement probe defined by the IEC 61967-4 standard, 
also known as 1 ɋ method. The meaning of the components forming the circuit model is 
given in Table 3- 1. 
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Figure 3- 1: The ICEM model of a 32-bit microcontroller (examples\emission\mpc\mpc_vde.sch) 

 

Parameters Description Remarks 

Ib Current source  

Unit: Ampere 

Description: piece-wise-linear 

The Ib current is described as a 
periodic triangle (1.2 A max) 

Cd Decoupling capacitance  

Unit: Farad 

Description: discrete C 

Cd is 4 nF, which is quite high due 
to on-chip added capacitance 

Lvdd_die, 
Lvss_die 

Series internal inductance  

Unit: Henry 

Description: discrete L 

The series inductance is tuned to 5 
nH, which provokes a resonance 
effect with Cb around 300 MHz. 

Rvdd_die, 
Rvss_die 

Series internal resistance  

Unit: Ohm 

Description: discrete R 

Around 1 ohm series resistance 
due to long on-chip metal traces 

Cb Block decoupling capacitance  

Unit: Farad 

Description: discrete C 

Local block capacitance, around 
200 pF. 

Rvde, R49, Rsa Current probe, matching resistors, 
and input impedance of spectrum 
analyser respectively 

Unit: Ohm 

Description: discrete R 

The current probe resistor is 
usually equal to 1 ohm. To reduce 
voltage drops across this resistor, it 
has been replaced by 0.1 ohm. 
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Table 3- 1: Details on the circuit modelôs electrical components 
(examples\emission\mpc\mpc_vde.sch) 

 

Lvdd and Lvss concern the package, and account for the series equivalent inductance from 
the IC die to the physical supply source and the VDE probe. Notice that the series resistance 

is 0.1 W instead of 1 W due to the high current flowing inside the IC. Placing a 1 W series 
resistance would dissipate nearly 1 W and induce a voltage drop of around 1 V, which is 
unacceptable. The voltage measured by spectrum analyser VSA across the 0.1 ɋ resistor is 
related to IC current Ignd returning to the ground through the resistance by the following 
theoretical relation (if PCB and passive device interferences are ignored). 

gndVDESA IRV
2

1
=  Equ. III-1 

III.1.2 Current Source Description 

The internal activity of a circuit corresponds to charge/discharge cycles which can be 
modelled by one or more current sources. The most basic description is that of a pulse 
waveform. This modelling approach has been adopted by the ICEM standard. A time-
dependent waveform is assigned to the current source for transient analysis. There are five 
independent source functions: pulse, exponential, sinusoidal, piece-wise linear and single-
frequency FM. In the schematic editor, the pulse is described, as shown in Figure 3- 2. The 
pulse description restricts the Ib shape to a periodic pulse, which is triangular if the pulse 
width parameter is set to zero. 

 

Figure 3- 2: Current Pulse parameters in the schematic editor (mpc_vde.sch) 

 

PULSE(I0 I1 TD TR TF PW PER)  

Example: IIcpu 5 7 PULSE(0 1.2A 1.0n 1n 1n 0.5n 50n)  

 

Parameter Description Unit 
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I1 pulsed value Amps 

TD rise time TSTEP seconds 

TF fall time TSTEP seconds 

PW pulse width TSTOP seconds 

PER period TSTOP seconds 

Table 3- 2: Current source description under SPICE  

III.1.3 Power supply Description 

The power supply is modelled by a constant voltage source. In Erreur ! Source du renvoi 
introuvable., the constant voltage source has a DC value of 3.0 V. 

 

Figure 3- 3: Constant voltage source (examples\emission\mpc\mpc_vde.sch) 

III.1.4 Analysis Description 

In the editing window, a command line is added to set up the desired analysis. The line must 
start by '.TRAN' for a transient analysis. In Figure 3- 4, the time-domain analysis is set to 
1000 ns, with a simulation step of 0.1 ns.  

This text sets the analysis to 
the desired mode (.TRAN in 
this case)

 

Figure 3- 4: Defining the SPICE simulation parameters 
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Two methods are used to insert an analysis line on the schematic: 

Á click on button or in the "Edit > Text" menu, directly type the SPICE analysis command  

Á in the Insert menu, click on ñInsert analysis lineò. An interface dedicated to the configuration 

of the SPICE simulation is opened and the analysis line is automatically inserted on the 

schematic with the correct syntax. 

III.1.5  Create the SPICE file 

IC-EMC can build netlist files .cir compatible either 
with WinSPICE, Ngspice or LTSPICE. The 
selection of the simulator is made in the menu "File 
> Simulator". The simulator is launched either 
manually by the user or automatically after the 
generation of the netlist, depending on the selected 
options in the menu "File > Simulator > 
Configurations". In this example, we select 
WinSPICE as simulator. It will be launched 
manually: in the menu "File > Simulator > 
Configurations", select the option "Launch 
simulator manually".  

Use command File ­ Generate Spice file or select <Ctrl>+<G> or click on the button  in 
the command bar. The following screen appears (Figure 3- 5). This creates a file called 
ñmpc_vde.cirò, which contains the circuitôs netlist description. This is the input file for the 
WinSPICE simulator. 

 

Figure 3- 5: The SPICE file generated from the schematic diagram 
(examples\emission\mpc\mpc_vde.sch) 

III.1.6 Run SPICE Simulation 

As explained in III.1.5, we select WinSPICE as SPICE simulator. We also choose to launch 
the simulator manually. Start the WinSpice program and click on "File > Open" (Figure 3- 6). 
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Select the desired .CIR file, i.e. the file generated by IC-EMC during the previous step 
(examples\emission\mpc\mpc_vde.cir). The simulation is performed in the time domain, and 
the following screen appears. The .TRAN analysis simulates the first 1000 ns of the transient 
evolution of the signal. The result is stored in a file called ñmpc_vde.txtò. By default, the plot 
of the transient simulation appears in a new window shown in Figure 3- 6. 

 

 

Figure 3- 6: The initial WinSPICE screen (top) and transient simulation performed by WinSPICE 
(bottom) 

III.1.7 Plot the transient waveform 

The transient waveform of the voltage across the 0.1 ɋ resistor can be plotted in IC-EMC by 

clicking in the menu "EMC > Voltage vs. time" or on the button  in the command bar, as 
shown in Figure 3- 7. The list of signals saved by the simulator is given in the list Signals in 
the menu "Simulation Data" in the right part of the window. The signal name is "V(9)", where 
V indicates that we monitor a voltage, "9" is the number of the monitored node in the 
schematic. 

Remark: click on the menu "View > View electrical net" or on the button  to display all the 
nodes directly on the schematic. 

Right-clicking on the graph returns the (time ; voltage) coordinate of the clicking position. 
Moreover, if you move the cursor while you're right-clicking, when the right-click is released, 
the X-Y shift between the initial and stop positions is shown. Amplitude and period of signals 
may be evaluated with this method. More details about this window will be presented in III.6. 
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Figure 3- 7: Transient profile of the voltage induced across the 0.1 ɋ resistor 
(examples\emission\mpc\mpc_vde.sch) 

III.1.8 Emission simulation 

The voltage waveform computed by the analogue simulator is translated into the frequency 
domain according to two methods: 

Á FFT mode: by default with a Fast Fourier Transform (FFT) 

Á EMI receiver mode: the effect of the intermediate frequency (IF) filter of an EMI receiver 

followed by a peak detector is simulated. The parameters of this mode should be set carefully 

because the computation time may be long. 

The X-axis should cover the 1-5000 MHz range in a linear or logarithmic scale. The energy 
along the Y-axis is in dBµV or V (dBµA and A if results expressed in current are imported). In 

the command bar, click on button 'Emission vs. Frequency' , or click "EMC > Emission 
vs. Frequency". A specific screen opens with Log/Log units configured to display voltage or 
current vs. frequency, as shown in Figure 3- 8. The main commands of this window are 
dispatched in several tabs: 

Á Input data: import of simulation (.txt from WinSPICE and Ngspice, and .raw from LTSPICE) 

and measurement result files (measured spectrum .tab and measured transient waveform .tran), 

save FFT of simulated or measured results. 

Á FFT Parameters: selection of the FFT mode or EMI receiver mode, selection of the FFT and 

EMI receiver parameters for simulation and measurement results. 

Á Display: set the axis configuration (limits, lin/log mode), visibility of curves on the graph, 

change color of displayed curves, plot envelop of spectrum,  

Á Simu Data and Meas Data: list of simulation and measurement results. 

Á Envelop & Limits: set parameters for the extraction of envelop of simulated or envelop 

spectrum, add a standard EMC limit. 
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By default, if the schematic is opened and if the SPICE simulation runs correctly, the FFT 
mode is selected. A FFT is performed and the simulation results are directly plotted when the 

window opens. If the result is not displayed, click the  button in ñSimulation input dataò part 
in the tab "Input data". Then select the file ñmpc_vde.txtò. It is possible to remove the initial 
period of the simulated waveform, from 0 to the value in the field "Skip (ns)". If the simulation 
results are correctly imported, Figure 3- 8 presents the obtained results. 

Plot of the FFT of the 
simulation results

Skip initial period

Import simulation 
results (.txt, .raw)

Show transient 
waveform

Show 
spectrogram

Cleargraph

Save simu. FFT

Close window

Messages

Select a simulated 
curveAdd a simulated FFT

Import meas. 
results (.tab, .tran), 
add and saved 
measured FFT

 

Figure 3- 8: Simulation of the microcontrollerôs conducted emission 
(examples\emission\mpc\mpc_vde.sch) 

 

The number of points N for the FFT (the FFT resolution) is a power of two and is adapted to 
fit the information included in the simulation and ensure the best resolution. Two FFT 
parameters can be adapted: 

Á the number of points or resolution of the FFT (maximum 262144) 

Á the windowing type: rectangular, Hamming and Blackman(Blackman by default) 
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The FFT resolution can be adjusted for the simulation and 
measurement results independently. The FFT resolution for 
the measurement results is visible only if a transient 
measurement results in .tran format has been imported. The 
number of points which form a displayed FFT result is equal 
to N/2. The frequency resolution ȹf is given by equation I-2 
and the maximum frequency Fmax by equation I-3. 

eNTT
f

11

max

==D  Equ. III-2 

eT
F

2

1
max=  Equ. III-3 

where Te is the sampling period of the transient signal, Tmax 
the duration of the transient signal. 

 

III.1.9 Comparison with Measurements 

In the "Input data" tab, click the  button in ñMeasurement input dataò and select the file " 
examples\emission\mpc\mpc_vde.tabò. Then click on the button "Add meas." to display the 
measured spectrum. Figure 3- 9 shows the comparison between measurements and 
simulations.  

The measurement curve is actually the envelop of the measured spectrum. The simulation 
fits the measured data up to 260 MHz except at 120 MHz, where the simulation is 10 dB 
above the measurement. Despite the discrepancy around this frequency, an acceptable 
correlation is obtained with a very simple model. Correlation with measurements may be 
improved, especially at high frequencies, by modifying the current profile, the IC internal 
power supply network and board models. 

The axis settings and the curve properties can be modified by changing the options available 
on tab Display. 
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Figure 3- 9: Comparison between measured and conducted emission for a microcontroller 
(mpc_vde.sch, mpe_vde.tab) 

 

 

III.2 Impedance analysis of the power supply network of a circuit 
mounted in a 64 BGA package 

This example presents the flow to simulate the impedance profile in frequency domain of the 
passive decoupling network (PDN) of a small 90 nm circuit mounted in a 64 ball grid array 
(BGA) package. The PDN is a macroscopic block defined by ICEM standard [ICEM] to 
describe the passive network which exists between several IC accesses, e.g the power 
supply network of a circuit. The accuracy of the PDN model is fundamental for emission and 
susceptibility predictions as it influences directly the noise propagation within the circuit. PDN 
modeling can be done either from Z parameter or S parameter representation. 

In IC-EMC, impedance analysis is intended for rapid simulation of the impedance Z(f) for 
single port devices. For multiport analysis or conversion to S parameter, it is advised to 
perform S parameter simulation, which is described in part III.3.  
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III.2.1 Load the example  

 

Load the file called 
ñexamples/impedance/FFIO90/ 
FFIO_90nm_Z_VDDE.schò. The 
electrical schematic is shown in 
Figure 3- 10. The schematic models 
the PDN of a small test chip 
fabricated in CMOS 90 nm containing 
several I/O structures [Boy08].  

The circuit is mounted in a 64-pin 
BGA package, as described in Figure 
3- 11.  

 

Figure 3- 10: PDN model of a test chip fabricated in 
CMOS 90 nm containing I/O structures 

(examples/impedance/FFIO90/ 
FFIO_90nm_Z_VDDE.sch) 

 

 

   

Figure 3- 11: 64-pin LBGA package [Boy08] 

 

Measurements have been performed using a Vector Network Analyzer (VNA) directly on the 
package balls with a coplanar probe placed between adjacent power pins VDDE and GNDE. 
The model has been extracted from the S parameter measurements. The PDN model 
includes two parts: 

Á the die contribution, i.e. interconnections and on-chip decoupling capacitances  

Á the package contribution, i.e inductive effects of balls, vias and bonding wires constituting the 

BGA package 

Table 3- 3 gives details of the elements of the model. 
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Parameters Description Remarks 

CVddeGnde Equivalent on-chip capacitance 

Unit: Farad 

Description: discrete capacitance 

This element models all parasitic and 

intentional on-chip capacitances between 

power supply VDDE and ground GNDE 

access.  

Lpck_vdde, 

Lpck_gnde 

Package parasitic inductance 

Unit: Henry 

Description: discrete inductance 

These 2 inductances model the contribution 

of all elements of VDDE and GNDE pins. 

With on-chip capacitance, they are 

responsible of the first resonance. 

Cpck_vdde, 

Cpck_gnde 

Package parasitic capacitance 

Unit: Farad 

Description: discrete capacitance 

These 2 capacitances model the 

contribution of all elements of VDDE and 

GNDE pins. They are added to model the 

package self resonance which appears 

above several GHz. 

RVdde, RGnde Total power supply and ground 

resistance 

Unit: Ohm 

Description: discrete resistance 

These resistors represent the resistive 

contribution of package and on-chip 

interconnections. Their effect is negligible 

except at resonance frequency. 

Table 3- 3: Details of basic elements of FFIO_90nm_Z_VDDE.sch  

III.2.2 Impedance probe description 

The impedance analysis corresponds to a simulation of the input impedance (also written Zin 
or Z11) seen from one circuit access relatively to a reference. In this example, the access is 
the power supply pin VDDE. The measurement is referenced to the ground pin GNDE.  

Impedance simulation is allowed only if an impedance probe or Z probe is placed in the 
schematic diagram. The Z probe (Figure 3- 12) is accessible from the palette. If you double 
click on the Z probe, the property screen is displayed, but without any specific property. 
However, the Z probe is not a transparent symbol. When placed on the schematic, it creates 
a voltage source with the description below: 

 

VZ 1 2 DC 0 AC 1 0  

é.. 

plot (V(1) - V(2))/I(VZ)  

Figure 3- 12: Impedance probe and associated SPICE description 

 

The voltage source associated to the Z probe is an AC source with an amplitude of 1 V. As 
may be found at the end of the SPICE netlist, a ñplotò control is associated with an equation 
which computes the impedance by dividing the voltage amplitude across the probe by the 
current provided by the impedance probe. 

 

Remark: use only one impedance probe per schematic diagram. The input impedance is 
linked to the current that a perfect voltage source delivers to a circuit. If a second AC voltage 
source is present, it will modify the current which flows along the branch of the first Z probe 
and hence the computed impedance. 
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III.2.3 Analysis description 

Impedance simulation is a small signal frequency analysis, so that it requires an AC 
simulation. The command line: " .AC DEC 100 1MEG 10G" is added to set up the desired 
analysis. The text must start by ó.ACô followed by the AC simulation parameters. The 
frequency sampling is logarithmic (option DEC) with 100 points per decade between 1 MHz 
and 10 GHz. Two methods are used to insert an analysis line on the schematic: 

Á click on button or in the "Edit > Text" menu, directly type the SPICE analysis command  

Á Click on ñInsert > Insert analysis lineò. An interface dedicated to the configuration of the 

SPICE simulation is opened (Figure 3- 13) and the analysis line is automatically inserted on 

the schematic with the correct syntax. 

 

Figure 3- 13: Insert AC simulation command line on the schematic ("Insert > Insert analysis line") 

III.2.4 Run SPICE simulation 

In this example, WinSPICE is used as simulator. In the menu "File > Simulator", select 
"WinSPICE". Then, click on "File > Simulator > Configurations" to set the options of the 
simulators. The right window of Figure 3- 14 opens. The upper part gives the access path of 
the simulator. They have to be set up correctly before any simulation. In the lower part, three 
simulator launching options are proposed: 

Á Launch simulator manually: when the user generates SPICE netlist , he has to launch the 

simulator, opens the circuit netlist (.cir file) and launch the simulation 

Á Interactive mode: when the user generates SPICE netlist , the simulator is automatically 

launched and remains opened at the end of the simulation to analyze the result 

Á Batch mode: when the user generates SPICE netlist , the simulator is automatically 

launched but is closed directly at the end of the simulation 
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Figure 3- 14: Select simulator and configure the simulator options 

 

In this example, select "Interactive mode" and click on the button OK. The simulator options 
are kept for the next simulations, until you change them.  

Use command File ­ Generate Spice file or click on the button  in the command bar. The 
SPICE netlist FFIO_90nm_Z_VDDE.cir is generated. WinSPICE is automatically launched 
and the impedance simulation is done. The following screen appears. WinSPICE can be 
closed at the end of the simulation. 

 

Figure 3- 15: AC simulation performed by WinSPICE (FFIO_90nm_Z_VDDE.txt) 

III.2.5 Impedance analysis 

The impedance profile vs. frequency computed by WinSPICE can be displayed in a specific 
screen dedicated to impedance analysis. In the SPICE generator menu, click "Impedance 

Window", or click "EMC" ­ "Impedance vs. Frequency". Alternatively, you may click the 

icon . A specific screen with Log/Log units configured to display impedance vs. frequency 
is proposed, as shown in Figure 3- 16.  

The main commands of this window are dispatched in several tabs: 

Á Parameters: X-Y axis configuration (lin/log display mode), add basic R, L, C impedance 

profile 

Á Display: display simulation, measurement, recorded results 

Á Freq: list of simulation and measurement results 
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By default, if the schematic is opened and if the SPICE simulation runs correctly, the Z(f) 

profile is plotted. If the result is not displayed, click the  button on the right of ñSPICE simuò 
and select file ñFFIO_90nm_Z_VDDE..txtò. 

Simulated/ measured
Z(f) plot

Configuration of 
the Y axis

Configuration 
of the X axis

Add R, L, C 
impedance profile

Simulation file 
path (.txt)

Record simu/meas. 
curves

Clear graph

Save simu. Z(f)

Close window

Add meas. Spectrum 
(.z, .s1p)

Insert R,L,C on 
schematic

 

Figure 3- 16: Input impedance simulation performed by WinSPICE (examples/impedance/FFIO90/ 
FFIO_90nm_Z_VDDE.sch) 

At low frequency, impedance tends to decrease due to the on-chip capacitance effect. At 180 
MHz, the first resonance linked to the on-chip capacitance and the package inductances 
appears. A second resonance due to package inductance and capacitance appears at 5.4 
GHz.  

To verify the on-chip capacitance of the circuit from the Z(f) profile, click on the box "Add" in 
the tab Z(f) and select C. Type 183 pF in the field "Value" and click on the button "Plot Z(f)". 
The Z(f) profile of a 183 pF is displayed and is tangent to the Z(f) profile of the circuit PDN in 
low frequency. It confirms that the total on-chip capacitance is about 183 pF. This basic tool 
can also be used with Z(f) measurement to extract equivalent resistance, capacitance or 
inductance. 

III.2.6 Comparison with measurement 

In the impedance window, click on the button ñAdd Measò to display the impedance 
measurement of the PDN of the circuit.  The measurement data are available in the file 
called ñexamples/impedance/FFIO90/Z11_FFIO_VDDE_A4B5.zò. The comparison between 
measurement and simulation is presented in Figure 3- 17 and proves the validity of the 
model up to 3 GHz. 
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Figure 3- 17: Comparison between measured and simulated input impedance of the PDN of the 90 nm 
circuit (examples/impedance/FFIO90/ Z11_FFIO_VDDE_A4B5.z) 

 

 

III.3 S parameter analysis for model construction of a bias tee 

A typical method to construct electrical models of components is based on equivalent R, L,C 
networks extracted from S parameter measurements. Here, we present an example of 
comparison between measurements and simulations of two-port S parameter done on a 
home-made bias tee. A bias tee is a three-port decoupling network used to superimpose a 
low frequency signal and a high frequency signals. The bias tee ensures the isolation 
between the low frequency and the high frequency signal sources. A bias tee is required in 
IEC62132-4 Direct Power Injection (DPI) test in order to superimpose a conducted 
aggression on a low frequency signal (input signal or power supply). The name given to the 
three ports of the bias tee are: 

Á a low frequency (LF) input 

Á a radiofrequency (RF) input, connected to the RF disturbance source 

Á the output with the signal resulting of the superposition of both inputs 

The LF input is isolated from RF signal by a resistor, inductor or ferrite which filter high 
frequency signal. Resistors should be avoided if DPI is conducted on a power supply 
because of the power dissipation. The RF input is isolated from low frequency signal by a 
series capacitor. Figure 3- 18 presents a bias tee dedicated to DPI test on the frequency 
range 10 MHz ï 3 GHz. It is build with several passive devices mounted on a PTFE 
substrate board. Input and output SMA connectors are connected by 50 ɋ microstrip line. A 1 
nF capacitor and a 1 µH inductor isolate RF and LF input from each other. 
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 1 nF X7R 
capacitor

1 µH 
inductor

RF input Output

LF input

   

Figure 3- 18: Home-made bias tee for DPI tests 

 

Values of inductors and capacitors are chosen in order to give the three following properties 
to the bias tee: 

Á A small reflection coefficient at RF input over all the targeted frequency range. It should be 

inferior to -10 dB to reduce input return loss. 

Á A high isolation or transmission coefficient from RF input and LF input over all the targeted 

frequency range. It should be less than -10 dB to prevent from RF leakage to LF source. 

Á A high transmission coefficient from RF input to output over all the targeted frequency range. 

It should be greater than -3 dB to enhance RF transmission to the output. 

III.3.1 Load the example 

Open the file "examples\emc_lib\3_port_bias_tee.sch". The schematic is shown in Figure 3- 
19. Models of microstrip line are lossless 50 ɋ transmission line, their delay time have been 
computed from physical length and dielectric constant of the substrate. The capacitor and 
inductor models have been extracted previously. A parasitic serial inductor is added to the 
capacitor while a parallel capacitor is added to the inductor to induce self-resonance. 
Resistances are added to reduce their quality factors. Three S parameter probes are placed 
at each terminal of the model so that a full 3×3 scattering matrix can be simulated.  
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Figure 3- 19: Model of a bias tee optimized for the frequency range 10 MHz ï 3 GHz 
(examples\EMC_lib\3_port_bias_tee.sch) 

III.3.2 S parameter probe description 

S parameter simulation is allowed only if at least one S parameter port probe is placed within 

the schematic. The S parameter probe is accessible from the palette with the symbol . 
Double clicking on the probe opens their property screen (Figure 3- 20). A S parameter 
probe is characterized by a user name, a unique number, a characteristic impedance Z0 
(which must be common to every port) and a DC voltage. A port can be disabled so that it is 
replaced by a resistance with a value of Z0.  

 

Figure 3- 20: S parameter port probe properties 

 

A S parameter probe is formed by a sine waveform voltage source with a series resistance 
Z0. The amplitude of the voltage source is equal to 0 or 1 V depending if the probe is 
activated or not. Figure 3- 21 presents a representation of a 2-port device characterized by S 
parameters. S parameter probes are composed of small signal sinusoidal source and 
reference impedance Z0 connected to device terminals.  
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plane
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Figure 3- 21 : S parameter characterization of a 2 port device 

 

The four parameters, listed below, allow a complete characterization of power exchanges 
between the 2 ports. They form the S parameter matrix. This principle can be extended to 
device with any port number. 

Input reflection coefficient 

2

1
11

1 0a

b
S

a
=

=  

No power fed from port 2. 

Port 2 terminated by Z0 to prevent from reflection at 

port 2. 

Output reflection coefficient 

1

2
22

2 0a

b
S

a
=

=  

No power fed from port 1. 

Port 1 terminated by Z0 to prevent from reflection at 

port 1. 

Forward transmission coefficient 

2

2
21

1 0a

b
S

a
=

=  

No power fed from port 2. 

Port 2 terminated by Z0 to prevent from reflection at 

port 2. 

Forward transmission coefficient 

1

1
12

2 0a

b
S

a
=

=  

No power fed from port 1. 

Port 1 terminated by Z0 to prevent from reflection at 

port 1. 

Table 3- 4 : Definition of the S parameters for a 2 port device 

 

S parameter matrix can be converted into other forms (impedance, admittance, ABCD é). 
For electrical modeling purpose, impedance is a convenient representation. The conversion 
between [S] to [Z] parameter matrices is given by the following equation, where [I] is the 
identity matrix. 

[][]
[][]SI

SI
ZZ

-

+
= 0][  Equ. III-4 

Remarks: if other probes (e.g. voltage, current or impedance probes) are present on the 
schematic, S parameter analysis is cancelled. Internal voltage source amplitude is set to 0 V, 
so each port is loaded by 50 ohms. The number of ports is limited to four. If more ports are 
added, they will be ignored and will be replaced by 50 ɋ resistances.  
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III.3.3 Analysis description 

S parameter simulation requires a small signal or AC simulation. A text line is added on the 
schematic which sets up the desired analysis. The text must start by ó.ACô followed by the AC 
simulation parameters. In Figure 3- 19, the frequency sampling is logarithmic, with 100 points 
per decade between 300 KHz and 3 GHz. The analysis line can also be inserted with the 
command 'Insert' Ą 'Insert analysis line'. Two methods are used to insert an analysis line on 
the schematic: 

Á click on button or in the "Edit > Text" menu, directly type the SPICE analysis command  

Á Click on ñInsert > Insert analysis lineò. An interface dedicated to the configuration of the 

SPICE simulation is opened and the analysis line is automatically inserted on the schematic 

with the correct syntax. 

III.3.4 Run SPICE simulation 

Select WinSPICE as simulator in "File > Simulator". In the menu "File > Simulator > 
Configurations", select "Interactive mode" to launch SPICE simulation automatically after the 

SPICE netlist generation . 

III.3.5 S parameter analysis 

Click "EMC > S parameters" to open the [s] parameter display screen. Alternatively, you may 

click the icon . A specific screen with a blank screen and a menu on the right appears. 
Simulation results can be plotted by selecting the quantity to plot (S11, S12, é) and its 
format (magnitude, phase, real or imaginary part) in the "Simulation data" part and clicking on 

the button "Add Simu" . The graph can be plotted either in cartesian or Smith chart 
mode ("Display mode"). The result can be converted either in S or Z parameters, or mixed-
mode parameters when 2 or 4 ports are placed on the schematic ("Conversion") (an example 
with mixed-mode S parameters is given in III.9.2). The X and Y axes boundaries and lin/log 
format can be set in "X axis" and "Y axis" parts. 

In order to check the three properties of bias tee listed in III.3, set the format to "Mag 
(linear)", select successively the quantities "SRFRF", "SRFLF" and "SRFOUT" an click on 
"Add Simu" to plot the RF input reflection coefficient, the RF-LF isolation and the RF to OUT 
transmission respectively. In "Display mode", select "Cartesian", and choose "S" in 
"Conversion" to plot S parameters. In "X axis" and "Y axis" parts, check the box "Log" to plot 
the axes in logarithmic mode. Figure 3- 22 shows the result that you should obtain. 
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Figure 3- 22: S parameter simulation of a three port bias tee (examples\EMC_lib\3_port_bias_tee.sch) 

The simulation shows that the RF input reflection coefficient (SRFRF parameter) is low 
between 10 MHz and 3 GHz while the transmission coefficient from RF to OUT terminals 
(SRFOUT parameter) is nearly equal to 1. The bias tee ensures an efficient transfer of the 
RF energy to a 50 ɋ load connected to the output of the bias tee. The transmission 
coefficient between RF and LF terminals (SRFLF) is also small between 10 MHz and 3 GHz, 
proving the good isolation between the RF and LF sources. 

The results can be plotted in Z parameter format if you select "Z" in "Conversion part". Click 
on the button "Redraw" to fit automatically the X and Y axes boundaries. The curves shows 
respectively the RF input impedance (ZRFRF parameter), the RF to LF and RF to OUT 
transfer impedances (ZRFLF and ZRFOUT parameters).  

 

Figure 3- 23: Conversion from S to Z parameters (examples\EMC_lib\3_port_bias_tee.sch) 
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The simulation results can be exported in the common Touchstone format .snp, where n is 
the number of ports and is limited to 4 in IC-EMC. Click on the button "Save Simu." and type 
the name of the exported file. As there are three ports, the file is saved in a .s3p file.  

III.3.6 Comparison with measurement 

In the "S parameter measurement" part, click on the button  to import measurement files. 
They are in Touchstone format .s1p, .s2p, .s3p or .s4p. The tool can import measurements 
with up to four ports. Import the file xxx, select the quantity in "S parameter" list and the 
format in "Format" list. Finally, click on the button "Add meas." to plot the measurement 
results, as shown in the figure below. 

 

 

 

 

III.4 Simulation of the conducted immunity on the power supply of a 
microcontroller 

This example aims at presenting the flow to simulate the susceptibility of a circuit to 
radiofrequency interference (RFI). In this short case study, a sine wave disturbance is 
conducted on the power supply network of a digital circuit until the noise level measured on 
the pin of an output buffer exceeds a predefined noise margin. The circuit under test is a 16-
bit microcontroller (HCS12X or S12X from Freescale Semiconductor). Conducted emission 
measurements are related to the standard IEC 62132-3 Direct Power Injection (DPI) method 
[IEC62-4]. The test covers the frequency range from 1 to 1000 MHz. The immunity model is 
based on an equivalent R,L,C circuit modeling the power distribution network (PDN) of the 
circuit, which was extracted from [s] parameter measurement.  

 

III.4.1 Load the S parameter simulation model 

Load the file called ñexamples\immunity\S12X_RFI\S12XPowerSupply_S11.schò, as 
described in Figure 3- 24. The model has been extracted by a vector network analyzer 
measurement from 300 KHz up to 3 GHz, which has been performed through a SMA 
connector on the power supply plane. It provides a simplistic version of the equivalent 
electrical model of the PDN of the microcontroller between power supply VDDR and ground 
VSSR pins. A S parameter probe is placed between VDDR and VSSR pins in order to 
perform a simulation of the impedance connected between these pins. Information about the 
elements of the model is given in Table 3- 5. The measured S11 parameter used to extract 
this model is given in the file S12XPowerSupply_S11Meas.s1p. Refer to part III.3 to simulate 
the impedance of the microcontroller's PDN and compare it with measurements. 
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Figure 3- 24: Basic PDN model of the S12X microcontroller 
(examples\immunity\S12X_RFI\S12XPowerSupply_S11.sch) 

 

Parameters Description Remarks 

LVddR, LVssR Package and board parasitic 

inductance 

Unit: Henry 

Description: discrete inductance 

These 2 inductances model the contribution 

of all the Vdd and Vss pins of the S12X 

package and the parasitic inductance of 

power supply and ground planes of the 

board 

RVddR, RVssR Package and board parasitic 

resistance 

Unit: Ohm 

Description: discrete resistance 

These resistors represent the resistive 

contribution of all the elements between Vdd 

and Vss (board, package, die). 

CVddVssR Circuit and board capacitance 

Unit: Farad 

Description: discrete capacitance 

This capacitance models the total 

capacitance between Vdd and Vss. It is the 

sum of board interplane capacitance and all 

the on-chip capacitances between Vdd and 

Vss 

RVddVssR Loss resistance 

Unit: Ohm 

Description: discrete resistance 

This resistance is added between Vdd and 

Vss and models all the dielectric losses 

between power and ground plane and on-

chip leakage between Vdd and Vss  

Table 3- 5: Details of basic elements of S12XPowerSupply_S11.sch 

 

III.4.2 Load the susceptibility simulation model 

A basic susceptibility to RFI model is built from the extracted PDN. Load the file 
ñexamples\immunity\S12X_RFI\RFI_S12XPowerSupply.schò described in Figure 3- 25. This 
schematic models the conducted injection of RFI in the power plane of the S12X board 
according to the IEC 62132-3 DPI standard. The susceptibility of the circuit is evaluated 
according to the RF noise coupled on the pin of an output buffer of the microcontroller and 
measured with an oscilloscope. The output buffer is tight to a 5 V voltage. The circuit is 
considered failed when the amplitude of noise measured with the oscilloscope exceeds 1 V 
(20 % of the supply voltage).  
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Figure 3- 25: Basic model for conducted susceptibility prediction of the S12X microcontroller 
(examples\immunity\S12X_RFI\RFI_S12XPowerSupply.sch)  

 

Several new elements have been added in the schematic, which are detailed in Table 3- 6. 

Elements Description 

Injection device and 

coupler 

The injection device is used to produce the RF disturbance and consists 

in a sinusoidal source with a 50 ohms output resistor. Frequency and 

amplitude of the RF disturbance varies during simulation and are 

controlled by user defined parameters. A coupler is added in the model to 

measure the forward power required to induce a failure. See chapter 7 for 

more information about susceptibility simulation. 

Bias tee This element composed of an injection capacitor and a choke inductance 

is required to superimpose a RF disturbance to a low frequency signal 

(e.g. the power supply voltage). 

Power decoupling network 

(PDN) 

A simple PDN model has been extracted from S parameter measurement. 

Output IO A simplified model of an output buffer has been built from the IBIS file of 

S12X (see chapter 4 for more information on IBIS file and chapter 8 for 

more details on S12X models). The model contains only the output buffer. 

Effects of clamp diodes, pad, package and tracks have been removed to 

simplify the model. 

Oscilloscope A large band oscilloscope is used to detect a failure during the 

susceptibility test. The output buffer is sensed by an active probe 

modeled by a parallel RC. The simulated susceptibility criterion is the 

voltage across this probe. 

Table 3- 6: Details of basic elements of RFI_S12XPowerSupply.sch 
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III.4.3 Configure the susceptibility simulation 

A RFI source is inserted in the schematic 
to perform a susceptibility simulation. It 
consists in evaluating the required forward 
power produced by a RFI source to induce 
a predefined failure at different 
frequencies. A transient simulation is used 
to extract the forward power for a 
sinusoidal RFI disturbance at a fixed 
frequency. The amplitude of the RFI 
voltage is increased linearly during all the 
simulation, a post-processing is required 
to detect if a failure appears during the 
simulation and extract the forward power. 
The transient simulation is repeated for 
each frequency of the test.  

The first step is the configuration of the 
susceptibility simulation. Click on the 
menu ñEMC > Susceptibility dBm vs. 

frequencyò or on the icon. The tool 
includes two screens: one to control the 
simulation, and the other to display the 
extracted susceptibility threshold. 

RFI source 
configuration

Transient simulation 
duration

Failure 
detection

Susceptibility 
limit extraction

SPICE model 
generation

Compute 
susceptibility limit

Display susceptibility limit 
in frequency domain

Frequency 
sweeping mode

 

Figure 3- 26: Configuration of the simulation of 
susceptibility 

The disturbance source, susceptibility criterion and transient simulation are configured using 
this window. The screen used to control the simulation is described in Figure 3- 26. It 
proposes three tabs dedicated to three simulation modes linked to the RFI frequency 
sweeping method: 

Á Manual simulation mode: the user configures a transient simulation at one RFI frequency. The 

user manually sweeps the frequency.  

Á Automatic simulation mode (default mode): the user configures N transient simulations for N 

RFI frequency points. The RFI frequency is swept linearly or logarithmically.  

Á List simulation mode: this uses the same principle as automatic mode, but the frequency 

sweeping is defined in a text file. 

In this case study, only the automatic mode is considered. The user defines the frequency 
sweep: here, 20 points ranged logarithmically between 1 and 100 MHz (10 points per 
decade). Then, the RFI amplitude sweep is configured, either in term of RFI source voltage 
or forward power. Here, the minimum power is set to 15 dBm while the maximum power is 
set to 45 dBm. The smaller the amplitude sweep range, the better is the accuracy of the 
simulation result. Finally, configure the transient simulation duration, defined in absolute time 
or according to a given number of RFI periods. Set it to 100 RFI periods for every test 
frequencies. The longer the simulation time, the better is the accuracy of the simulation 
result. 

 

III.4.4 Run SPICE simulation 

In the current version of IC-EMC (version 2.9), the susceptibility simulation is not supported 
by LTSPICE. In the menu "File > Simulator", verify that WinSPICE has been selected. 
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In the simulation control screen presented in Figure 3- 26, click on the button ñGenerate 

SPICEò  to generate the circuit netlist file RFI_S12XPowerSupply.cir and run the transient 
simulation over the different frequencies. In the menu "File > Simulator > Configurations", 
depending on the simulator options, the simulation is launched automatically or manually. If 
the option "Launch simulator manually" is chosen, in WinSPICE, click "File > Open" and 
select the file RFI_S12XPowerSupply.cir. As the susceptibility simulation is configured for 20 
frequency points, the transient simulation is repeated 20 times. The status of each simulation 
is displayed on WinSPICE interface (Figure 3- 27).  

 

Figure 3- 27: Susceptibility simulation performed by WinSPICE and frequency sweep 

 

III.4.5 Observation of the output signal of the buffer 

The susceptibility of the buffer depends on the RF noise coupled on the output buffer. In 
order to visualize the transient waveform at the output buffer during the RF injection, observe 
failure and find the failure time, click on the menu "EMC > Voltage vs. time" or on the button 

. The results of the simulation are recorded in text files with the prefix "sweep_RFI_" 
followed by the schematic name and ended by the number of frequency sweep. For 
example, the file " sweep_RFI_RFI_S12XPowerSupply1.txt" is the result of the susceptibility 
simulation for the first RFI frequency, i.e. 1 MHz. This file contains the transient evolution of 
the voltage recorded by the voltage probe and the forward and reflected power. 

In the "Voltage vs. time" window, click on the button  and select the file 
sweep_RFI_RFI_S12XPowerSupply1.txt. Then select "V(10)" in the list "Signals" to observe 
the voltage induced at the output buffer. Finally click on the button "Add Simu" to plot this 
curve. The result is shown in Figure 3- 28. A sine waveform is superimposed to the nominal 
5 V voltage delivered by the output buffer. The amplitude of the coupled noise linearly 
increases with time, since the amplitude of the RF disturbance increases linearly during the 
simulation. At 27 µs, the amplitude of the coupled RF noise exceeds 1 V so the 
microcontroller fails. 
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Figure 3- 28: Transient evolution of the voltage induced at the output buffer during the RFI injection at 
1 MHz 

III.4.6 Susceptibility threshold extraction and comparison with measurement 

Return to IC-EMC susceptibility simulation interface or click on ñEMC Ą Susceptibility dBm 

vs. frequencyò or on the icon again. To find all the files associated to transient simulation, 
a simulation control file *.ctl registers all the result files. If this file does not appear in the field 
ñSimulation control fileò, select the file ñRFIcontrol_RFI_S12XPowerSupply.ctlò. Then, the 
susceptibility criterion must be set. The nominal output signal is 5 V and the noise margin is 1 

V. Click on the button  to set upper and lower limits to the voltage captured by the voltage 
probe. In the fields "Up Volt. Limit" and  "Low Volt. Limit", type 6 and 4 which are the upper 
and lower limits respectively. Set also the maximum injected power to 45 dBm in the field 
ñPower limit (dBm)ò for the frequencies where a failure is not reached during simulation. 
Finally, click on the button ñGet powerò. The susceptibility threshold of the microcontroller 
according to the previous failure criterion is computed for the different RFI frequencies. The 
susceptibility threshold is expressed in forward power. 

At the end of this extraction, click on the button ñAdd Forward Powerò to plot the susceptibility 
threshold on a Power vs. Frequency graph, as shown in Figure 3- 29. In the tab 
"Parameters", the X/Y axes settings can be changed. In the tab "Freq.", the numerical values 
of the forward power are provided. The simulated susceptibility threshold can be saved by 
clicking on the button "Save". 

Click on the button ñAdd Measò and select the file ñsusceptibility_S12X_PDN.tabò to display 
the measured susceptibility threshold. Figure 3- 29 presents the comparison between 
measurement and simulation. Despite the gap that can reach up to 6 dB, simulated and 
measured thresholds follow the same trend and have the same order. This simple model 
provides an estimation of the susceptibility of the microcontroller rapidly. Increasing the 
complexity of board and circuit models could improve the accuracy of the simulation. 
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Figure 3- 29: Comparison between measurement and simulation of the susceptibility threshold of the 
S12X microcontroller (examples\immunity\S12X_RFI\RFI_S12XPowerSupply.sch) 

 

 

 

III.5 Load and analyze IBIS file 

As more and more attention is focused on the design of very high speed links, for example 
between processors and memories or display driver and LCD TFT screen, input/output (I/O) 
models are used for simulating the behavior of signal transport at very high data rate. The 
accuracy of the simulation relies on the quality of the models, both concerning the ICs and 
the PCB. Concerning the IC, the input/output buffer specification (IBIS) is recognized by IC 
manufacturers and users as a worldwide standard for describing IC interfaces to printed 
circuit boards for signal integrity predictions, without releasing any detailed technological 
information or confidential aspects of internal structure design [Ibis15]. In this part, we 
present the IBIS viewer of IC-EMC. With this tool, the user can read the content of an IBIS 
file, plot the characteristics of the models of the circuit's I/O, reconstruct 2D and 3D views of 
IC package and evaluate R,L,C stray elements of package interconnects. 

III.5.1 Load IBIS file 

An IBIS model is formatted as human-readable ASCII text. It is mostly based on extracted 
tables of generic structural elements.  IBIS models are component-centric; the IBIS model 
describes all pins of the physical component with an associated model. Keywords are 
denoted by square brackets, and a vertical bar serves as the default comment character.  
The IBIS file mainly contains the following elements: 

Á Information and Specification content starting with a header block [IBIS Ver] and also 
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presented elsewhere throughout the file 

Á Package information within each of one or more [Component] blocks and under a default 

[Package] keyword 

Á Pin out information within each of one or more [Component] blocks and under the [Pin] 

keyword giving pin-specific model references and optional pin-specific package values 

Á Model blocks beginning with one or more [Model] keywords.  

 

The software IC-EMC is able to extract information from IBIS files in a simple way and 

display it in the IBIS interface. Click on the menu "File > Load Ibis File" or on the button  in 
the command bar, and select the IBIS file ñexamples\ibis\ Xilinx_Spartan6_LVCMOS33.ibsò, 
which describe I/O characteristics of the FPGA Spartan6 from Xilinx, mounted in a BGA256 
package. The following screen appears (Figure 3- 30). In the left part, the content of the IBIS 
file is edited and can be read only. In the right part, four tabs appear: 

Á I/O: the list of the I/Os, the associated models and R, L, C stray elements given by IBIS file 

are summarized. 

Á Models: parameters of the I/O models are listed and their characteristics can be plotted (see 

III.5.2). 

Á Infos: general information about the IBIS file (version, date, manufacturer, etc), conditions 

and package are given 

Á Package: a 2D view of the package is reconstructed by IC-EMC from the pin list and 

keywords added by the user (see III.5.3). 

IBIS file content

List of I/O

Generate3D view
of package

ComputeR,L,C stray
elementsof package pins  

Figure 3- 30: Loading an IBIS file in the IBIS interface (examples\ibis\ 
Xilinx_Spartan6_LVCMOS33.ibs) 

 



 III. Working with IC-EMC 

 

56 

 

In the "I/O" tab, click the desired input pin in the I/O list, then click the button "One pin into 
RLC". The input pad is converted into a RLC circuit with on-chip capacitance and clamp, as 
shown in Figure 3- 31. It consists, from left to right, in an IO symbol with the input name 
(Here 'IO_L2P_0', the pin B5), the R,L,C parameters for the package (Here LIO_L2P_0, 
CIO_L2P_0, RIO_L2P_0), and the component input capacitance (Ccomp_IO_L2P_0). Notice 
the connection to the substrate potential ñVsubò. 

 

Figure 3- 31: Model of the PT0 pad (examples\ibis\ Xilinx_Spartan6_LVCMOS33.ibs) 

 

III.5.2 Plot I/O characteristics 

In an IBIS file, the [Model] block contains the data for electrical simulation of the pin interface. 
The Model_type sub-parameter classifies the model by types including Input, Output, I/O, 3-
state, etc.  Static I-V table blocks documented by [Pullup] and [Pulldown] keywords tabulate 
the transistor drive strengths. In the IBIS window of IC-EMC, the button ñPuò corresponds to 
the pull-up device of the I/O buffer, and ñPdò to the Pull-down device. The diodes are 
documented by [Power Clamp] and [Gnd Clamp] I-V tables (ñPcò for Power Clamp, ñGcò for 
Gnd Clamp). In CMOS technology, clamp diode currents come from P-N junctions.  These 
junctions act as protection circuits from voltage over-stress.  

Figure 3- 32 shows the tab "Models" of the IBIS interface. The file " 
Xilinx_Spartan6_LVCMOS33.ibs" contains six different model instances. Their main 
characteristics are summarized in the table in the upper part of the tab "Model". Let consider 
the model called LVCMOS33_F_12_LR33, which is the default model associated to each I/O 
of the FPGA (actually, each I/O support several I/O standards). It models a push-pull low 
voltage CMOS output buffer nominally biased under 3.3 V. The terms 'F' and '12' indicate two 
options of the I/O buffer: '12' is related to the drive (12 mA at VOL = 0.3 V), 'F' is related to the 
slew rate (fast). It can be seen from the example shown in Figure 3- 32 that pull-up and pull-
down I(V) characteristics are available (it is expected since it is a push-pull buffer). A ground 
clamp I(V) characteristic is available, but the I(V) characteristic of the power clamp is equal to 
0. According to the IBIS file, this output buffer has no power clamp protection. 

The button "Rw" and "Fw" means "Rising waveform" and "Falling waveform" respectively. 
Clincking on one of these buttons plots the rising or falling transient profile of the output 
voltage of the buffer. These V(t) profiles are given after the keywords [Rising Waveform] and 
[Falling Waveform]. They are used to evaluate the slew rate of the output buffer when it is 
load by a given load (usually 50 ɋ) and fits the command of the I/O in the I/O model. 
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Figure 3- 32: Plotting the I(V) characteristic of the pull-down device of the LVCMOS33_F_12 model 
(examples\ibis\ Xilinx_Spartan6_LVCMOS33.ibs) 

 

Data provided by IBIS can be used to build an equivalent model of the I/O. Static I(V) 
simulations can be done to fit the models of pull-down, pull-up or clamp devices. Transient 
simulations can be performed to verify the rising or falling waveforms of the I/O model. In the 
IBIS interface, in the tab "Models", user can import SPICE simulation results in .txt file in the 
IBIS interface by clicking on the button "Add data" and superimpose simulation results with 
I(V) or V(t) characteristics given by IBIS. 

III.5.3 Package viewer 

In most cases, accurate R,L,C evaluation of the package leads and bondings is not available 
in preliminary IBIS files. The purpose of the 2D and 3D-package reconstruction available in 
IC-EMC is to ease the extraction of package R,L,C elements and gives precise space 
localization of the package leads and bonding wires. This last point is very useful in EMC 
analyses, for localization of power supply and ground pins, or or near field radiated emission 
simulation (see III.8). 

III.5.3.1 Hidden Keywords 

Some important information is resourced in the IBIS file related to the package and IC 
physical dimensions. The information is placed in the [Package model] section, and starts by 
« | » to avoid parsing errors with conventional IBIS loaders. The physical dimensions are very 
important information to rebuild the lead frame structure of the package, together with the 
bonding structure and access to the die. Table 3- 7 provides a list of the important hidden 
parameters and associated description added in IBIS file, and used to configure the package 
viewer in IC-EMC. Figure 3- 33 illustrates the meaning of these geometrical parameters. 

Hidden parameter Description Example 
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pack_width Package width 20.1e-3 m 

pack_height Package height 20.1e-3 m 

ic_width Die witdh 6.55e-3 m 

Ic_height Die height 6.33e-3 m 

ic_xstart Die location in X related to the package 6.73e-3 m 

ic_ystart Die location in Y related to the package 6.84e-3 m 

pack_pitch Package pin pitch 0.5e-3 m 

ic_altitude Die altitude over the ground plane 0.8e-3 m 

pack_ball BGA ball radius 0.25e-6 m 

Table 3- 7: Hidden parameters stored in the [package model] section 
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Figure 3- 33 : Main parameters required for an estimation of the package R,L,C model 

 

Different package reconstruction methods exist and depend on the package type. The 
keyword [Package Model] provides information about the package type. 

Keyword Package types and variants IBIS example file 

[Package Model] bga Ball Grid Array (BGA) infineon_tc1796.ibs, 

Xilinx_Spartan6_LVCMOS33.ibs, 

virtexIIXC2V1500.ibs, 

prometheus_mmm6030_v2.ibs, bga64.ibs, 

mpc5534-324.ibs 

[Package Model] sop Small Outline Package (SOP) ahct04.ibs 

[Package Model] soic Small Outline Integrated Circuit (SOIC) l4949_v4.ibs 

[Package Model] qfp Quad Flat Package (QFP) Cesame_v14.ibs 

S12x_v2.ibs 

[Package Model] dil Dual in line (DIL) ds90lv049.ibs, NCP5603_v4.ibs 

Table 3- 8: Examples of package declaration in the ibis file (IBIS files available in examples\ibis) 

III.5.3.2 2D Package Viewer 

The need for reconstructing the 2D aspect of the package is justified by the need to locate 
pins (especially power supply and ground pins), and to provide accurate space coordinates 
of lead and bonding wires for near-field scan prediction. The external aspect of the IC with 
pin placement may be displayed by a click on the tab ñPackageò (Figure 3- 34).  
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Figure 3- 34: Package viewer (examples\ibis\ Xilinx_Spartan6_LVCMOS33.ibs) 

 

The yellow color corresponds to general purpose I/Os, the VDD supply pins are drawn in red, 
and the VSS pins in blue. Non-connected pins are drawn in gray. This 2D view gives details 
on the supply structure. It is also used by IC-EMC to compute the approximate position of a 
package lead. Considering the pin ñIO_L3P_0_D5ò selected in the list "Locate pin", an [X,Y] 
position is assigned to the lead which appears as a black line in Figure 3- 34. A group of pins 
(e.g. power supply pins) can also be located by selecting this group in the list "Locate pins". 

  

III.5.3.3 3D package Viewer 

The 3D-viewer is a visual assistant but do not include specific EMC features. The need for 
reconstructing the 3D aspect of a package is justified by the two following items: 

 

Á Compute accurate values for R,L,C of the package based on the physical dimensions of leads 

and bonding, if not provided in IBIS 

Á Provide accurate space coordinates for lead and bonding wires for near-field scan prediction 

 

The 3D package viewer gives a three-dimensional interactive view of the package. To create 
the 3D view, from the IBIS interface, click on the button "3D Draw". An example of 3D view of 
the BGA package of the Spartan 6 FPGA is given in Figure 3- 35. You may change the 
viewerôs position thanks to cursors X,Y and Z. The Z cursor serves as a zoom. The light 
position may be changed. The bonding, upper part of the package and the IC may be 
removed from the drawing. Finally, you may see a particular pin in the pin lists "Locate" in the 
lower corner of the userôs menu. The demo button makes an automatic rotation of the object, 
and the ñcloseò button closes the window. 
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Figure 3- 35 : 3D view of a BGA package (case study/tricore/infineon_tc1796_v2.ibs) 

 

III.5.4 Package modeling 

Refer to the example presented in III.8.3.1. 

 

 

 

 

 

III.6 Transient signal analysis 

This example aims at presenting the resources to analyze time-domain properties of signals. 
In this short case study, a complex signal is generated and its characteristics are studied. 
The following sections describe the different steps used to generate the signal and extract its 
characteristics. 

III.6.1 Signal generation 

In this example, a chirp modulated signal is considered. This type of signal is used in radar 
communications, but also in spread spectrum modulation (e.g. LoRa modulation). A chirp is a 
pseudo-periodic signal which frequency-modulated around a central or carrier frequency. 
The particularity is that the instantaneous frequency of the signal increases or decreases 
with time. In this example, we consider a linear chirp, i.e. the instantaneous frequency 
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changes with time linearly according to a constant parameter µ0 called chirp rate. A general 
expression of its waveform is defined by the following equation: 
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where FC is the central frequency, B is the bandwidth occupied by the signal and Tchirp the 
duration of the chirp. The chirp rate is given by the equation below. If µ0 is positive, the 
instantaneous frequency increases with time, otherwise it decreases. 

chirpT

B
°=0m  Equ. III-6 

The instantaneous frequency of such a signal is given by the equation below. It shows that 
the instantaneous frequency is linearly dependent of time. 
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In digital chirp-based modulation, the transmitted is composed of a series of chirp. 
Information is encoded either by sign of the chirp rate, or by a frequency offset added  to the 
instantaneous frequency (e.g. LoRa modulation).  

IC-EMC proposes a tool dedicated to the generation of complex waveforms that can be 
imported in SPICE schematics. Click on "Tools > PWL Source Generator" to open the 
window of signal generation. This tool aims at generating the time-domain profile of signals in 
SPICE compatible Piece-Wise Linear (PWL) format. The profile is defined by a series of 
pairs of value (Ti, Vi) where the value of the source is Vi (in Volts or Amps) at time=Ti. At 
intermediate values of time, the value of the source is interpolated. This profile can be saved 
in a text file and then imported in a SPICE netlist to describe the transient waveform of a 
voltage or current generator. 

The window shown in Figure 3- 36 opens. In the area "Select the mathematical operation", 
select "Linear up/down chirp". In the central part of the screen, the parameters of the signal 
can be modified: 

Á Samples and step: the number of pairs of value (Ti, Vi) of the PWL signal and the time step 

between two pairs 

Á Frequency FC: the nominal frequency of the chirp signal 

Á Amplitude A and offset: the amplitude and the offset of the chirp signal 

Á Chirp rate µ0: the linear increase or decrease rate of the instantaneous frequency of the chirp 

Á Chirp duration Tchirp: the duration of one chirp 
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Figure 3- 36 : PWL signal generator window ("Tools > PWL Source Generator") 

Here, we select the parameters shown in Figure 3- 36: the central frequency is 100 MHz, the 
chirp rate is 100 MHz/µs and one chirp lasts 1 µs. Thus, the bandwidth occupied by the chirp 
signal should be 100 MHz centered around 100 MHz. Here, the tool will generate 20000 
points separated by 0.1 ns, so the total duration of the signal will be 2 µs, i.e. two chirp 
duration. 

 Click on the button "Generate PWL" to display the waveform of the signal on the right part of 
the window. Click on the button "Save PWL" to save the PWL signal in a .txt file. The file 
pwl_chirp.txt has been saved in the directory "\examples\transient\". Click on the button 
"Close" to quit the window. 

III.6.2 Create the model 

Create a new schematic. Place a voltage source, a ground reference and a voltage probe, 
and save it. Double-click on the voltage symbol to edit its properties. Select Piece-Wise 
Linear and import the text file "\examples\transient\pwl_chirp.txt" by clicking on the button 

. Click on the button "OK" to validate and close the window. 

     

Figure 3- 37 : Model for simulation of chirp signal (\examples\transient\chirp_signal.sch) and PWL 
voltage source configuration 
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Configure the transient simulation : click on "Insert > Insert Analysis Line" and set a stop time 
of 10 µs and a step time of 1 ns.  

III.6.3 Run SPICE simulation 

Select LTSPICE as simulation in "File > Simulator". In "File > Simulator > Configurations", 
you can select "Batch mode" to launch LTSPICE simulation automatically each time the 

SPICE netlist is updated. Click on the button  to generate the SPICE netlist and launch 
the SPICE simulation. At the end of the simulation, the result is recorded in a .raw file 
(chirp_signal.raw). 

III.6.4 Observe the time-domain waveform 

Open the "Voltage vs. time" window by clicking in the menu "EMC > Voltage vs. time" or on 

the button  in the command bar. The window shown in Figure 3- 38 opens, showing the 
transient evolution of the chirp signal. Two tabs appears on the right side of the screen: 

Á Parameters: import simulation and measurement results, select signals to be displayed and 

display mode. 

Á Display: X/Y axes settings, show/hide curves, memorize curves 

If the curve is not plotted, you can import the simulation result 

(\examples\transient\chirp_signal.raw) by clicking on the button  in "Simulation Data" part. 
The signals (voltage and current) recorded in the .raw file appear in the list "Signals". Select 

the signal 'v(1)' and click on the button  to plot the chirp signal. The X and Y axes can 
be set with the commands proposed in the tab "Display". Zoom and curve memorization 
commands are also available. 
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Figure 3- 38 : Simulated waveform of the chirp signal (\examples\transient\chirp_signal.sch)  

 

Several characteristics or quantities of signals can be displayed, according to the selection 
done in "Quantity" field: 

Á Amplitude: this is the default displayed quantity 

Á Rise /fall time: 10%-90% rise and fall times 

Á Period and Frequency 

Á Duty cycle 

Á Jitter: phase jitter, period jitter or cycle-to-cyle (C2C) jitter 

 

These quantities can be displayed according to two different modes: 

Á "Time domain" mode: the evolution of the selected quantity is plotted in time domain 

Á "Probability density function" mode: an histogram showing the probability of occurrence of 

the values taken by the selected quantity is plotted 

III.6.5 Analysis of the instantaneous frequency of the signal 

Figure 3- 38 shows the transient evolution of the signal. Clearly, the signal is a sine wave 
whose frequency increases regularly during 5 µs. However, the exact evolution of the signal 
frequency is difficult to read accurately. To observe it, select "Frequency" in the "Quantity" 
field. The result is shown in Figure 3- 39 and confirms that the instantaneous frequency of 
the signal increases linearly from 5 MHz to 15 MHz for 5 µs periodically. The statistics of the 
instantaneous frequency can be found in the first row of the table "Statistics": the average 
frequency is about 10 MHz, while the minimum and maximum frequencies are nearly 50 and 
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150 MHz. The statistics is determined from 198 occurrences of signal periods. This figure is 
given in the last column of the table "Statistics". 

 

Figure 3- 39 : Evolution of the instantaneous frequency of the simulated chirp signal 
(\examples\transient\chirp_signal.sch)  

 

The distribution of the instantaneous frequency taken by the chirp signal can be plotted if you 
select the box "Probability density function" in the field "Display mode", as shown in Figure 3- 
40. The constructed histogram is centered around 100 MHz and shows the distribution of the 
frequency of the occurrence of chirp signal period.  
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Figure 3- 40 : Statistical distribution of the instantaneous frequency of the simulated chirp signal 
(\examples\transient\chirp_signal.sch)  

III.6.6 Spectrogram 

From the "Voltage vs. time" window, frequency analysis based on FFT can be done. Clicking 

on the button  opens the 'Emission Window' as described in III.1. A FFT of the full 
signal is computed, so that the evolution of the instantaneous frequency of the chirp signal 
cannot be displayed. A more interesting analysis of this signal is provided by a short-term 
FFT (SFFT) which can be computed with the tool Spectrogram. It can be opened with the 

button  or from the menu "Tools > Spectrogram". This tool display a 
representation of the signal in both time and frequency domains, as shown in Figure 3- 41. 
The amplitude of the signal is plotted according to a color code in a X-Y surface, where X is 
the time axis and Y the frequency axis. You can change the maximum displayed frequency 
by selecting the option "Max. Freq. (MHz)". An parameter of the SFFT is the FFT resolution 
Nreso. SFFT consists in performing successive FFT on MB time block of Nreso points. The time 
resolution of the SFFT is the duration of one time block. In this example, the maximum 
frequency is set to 500 MHz and the FFT resolution is set to Nreso = 1024 points. As the 
sampling period TE is 0.1 ns, the maximum frequency of the FFT is FE = 1/TE = 5 GHz. The 
duration of one time block, i.e. the time resolution is thus (Nreso-1)xTE = 102.3 ns. We can 
conclude that the lower the FFT resolution, the better the time resolution. However, reducing 
the FFT resolution degrades the frequency resolution. The frequency resolution dF is 
inversely proportional to the duration of one time block: dF = FE/(Nreso-1) = 4.89 MHz. The 
lower the FFT resolution, the worst the frequency resolution. 

In the example shown in Figure 3- 41, we can observe that the frequency increases linearly 
between 50 to 150 MHz for 1 µs. 
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Figure 3- 41 : Spectrogram or SFFT  of the simulated chirp signal 
(\examples\transient\chirp_signal.sch)  

 

 

 

III.7 Plot an eye diagram 

Eye diagram is a commonly used tool to assess the quality or the integrity of high-speed 
digital signals (Ethernet, USB3, HDMI, PCIe, etc). The transmission through transmission 
lines may distort the signal waveform because of impedance mismatch, attenuation, 
crosstalk with neighbour lines, simultaneous switching noise, etc. The amplitude and time 
distortion of the signal may lead to bit misinterpretation by the receiver. Eye diagram helps 
designers to view the signal impairments more easily, detect bandwidth limitation or the 
presence of excessive overshoots. 

The following sections aims at presenting how to plot the eye diagram of a digital signal and 
analyse its integrity. The proposed example addresses a link between two SSTL15 I/O 
buffers interconnected through a microstrip line. I/O buffers are described by macromodels 
built from IBIS file information.  

III.7.1 Eye diagram 

Figure 3- 42 describes the principle of the construction of the eye diagram of high-speed 
digital signal. It is essential to underline that eye diagram measurements concern only digital 
synchronous signals. Although eye diagrams apply for 2 or more level logic signal, only 
binary signals are considered in IC-EMC and in the following sections. 
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Let consider the transmission of a binary signal between a digital transmitter (TX) and a 
digital receiver (RX) through a series of interconnects. The data transfer is synchronized on 
the data clock rate FCLK. The construction of an eye diagram is based on a high bandwidth 
sampling of the signal data stream and an accumulation of the measured samples in order to 
superimpose all the states of the signal ('1' and  '0' levels, transitions from '0' to '1' or '1' to 
'0'). To obtain a stable picture, this sampling must be triggered on a clock which is 
synchronous with the captured digital signals. Thus the sampling is triggered at the signal 
binary data rate. Here, this clock signal is called the data clock.  
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Figure 3- 42: Principle of the construction of an eye diagram  

The display of an eye diagram is usually normalized for two clock periods and is centered on 
one bit period in order to capture the rising and falling transitions of the signal. The 
superposition of all the samples forms an eye, which gives the name to this diagram. A 
properly constructed eye diagram should contain every possible bit sequence, from simple '0' 
-'1' or '1' - '0' transitions to long sequences of '0' or '1'. 

Eye diagram provides an easy way to control the quality of the signal. The more open the 
eye is (horizontal and vertical aperture), the lower the likelihood that the receiver 
misinterprets the incoming signal. Noise and time jitter introduce some closure of the eye 
opening and increases the risk to confuse binary symbols (bit error rate (BER)). Moreover, 
any transitions that pass through the center of the eye opening may cause bit errors. 

However, eye diagram is not only a graphical representation to make qualitative 
assessments of signal integrity. Several indicators can be extracted to quantify the signal 
integrity. Figure 3- 43 describes the signal integrity indicators extracted from the eye 
diagram's tool of IC-EMC. There are two types of indicators: 

Á Amplitude or vertical indicators: 

1. Level '0' and Level '1': average value of the '0' and '1' levels in the 40-60 % region 
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2. Eye amplitude: difference between Level '1' and Level '0' 

3. Eye height or vertical aperture = (Level '1'-3xů1) - (Level '0'-3xů0), where 3xů1 and ů0 

are the standard deviations of sample distribution around Level '1' and Level '0' in the 

40-60% region. It is an indicator of the vertical eye opening. 

4. Eye crossing level: the amplitude of the transition crossing points.  

5. Eye crossing percentage = 100x(Eye crossing level - Level '0')/(Level '1' - Level '0'). It 

gives an indication of pulse symmetry. 

6. Signal to Noise Ratio (SNR): ratio of the desired signal level (eye amplitude) to the 

level of noise plus distortion. SNR = (Level '1' - Level '0')/( ů1+ ů0). The higher the 

SNR is, the lower the amplitude distortion. 

Á Time or horizontal indicators: 

7. Jitter: the time deviation from the ideal timing of a bit event (i.e. a transition) and its 

actual realization. Jitter is computed as the time variance of the rising and falling 

transitions at the crossing points. In IC-EMC, only the peak-to-peak jitter is computed. 

8. Eye width or horizontal aperture = (Right cross. point time - 3xůTr) + (Left cross. point 

time - 3xůTl), where ůTr and ůTl are the time variances of the rising and falling 

transitions at crossing points right and left. It is an indicator of the horizontal eye 

opening. 

9. Rise and fall times: 10 to 90 % rise or fall times. 
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Figure 3- 43: Signal integrity indicators extracted from eye diagram  

 

III.7.2 Load the example: DDR3 memory link 

In order to illustrate the creation of an eye diagram, we consider a DDR3 memory link  as 
example. Open the example in "examples\transient\ DDR3_link_400MHz.sch" by clicking on 
"File > Open". In the next part, we will modify this schematic diagram to plot the eye diagram. 

The schematic presented in Figure 3- 44 models a connection between a DDR3 driver 
(DDR3 TX) and a DDR3 receiver (DDR3 RX) through a microstrip line designed on a PCB. 
DDR3 or DDDR3 SDRAM is actually a type of synchronous dynamic random access 
memory. The term DDR3 is used to talk about the interface. The schematic models a link 
between a microprocessor and an external DDR3 SDRAM memory for example.  
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Figure 3- 44: Model of a DDR3 memory link (\examples\transient\DDR3_link_400MHz.sch) 

 

The microstrip line model is included in the subcircuit "microstrip_DDR3.sym". It was created 
based on the geometrical dimensions of the line by the tool "Tools > Interconnect 
parameters" (refer to III.9.1). The microstrip line is routed on a multilayer FR4 PCB. The 
dimensions of the line are: 

Á width = 0.127 mm 

Á height to the reference plane = 0.2 mm 

Á copper thickness = 35 µm 

Á length = 50 mm 

The characteristic impedance computed by "Tools > Interconnect parameters" is nearly 80 ɋ. 
The DDR3 driver and receiver comply with the SSTL15 standard specified by JEDEC 
Standard JESD79-3. It is a general-purpose 1.5V memory bus standard, which requires a 
termination voltage of 0.75V and a termination resistor of 50 ɋ. Output buffers are push-pull 
types. The driver and receiver have been modeled from information contained in IBIS file. In 
this example, the I/O buffer's models have been derived from IBIS file of a Spartan 6 FPGA 
available in "\examples\ibis\Xilinx_Spartan6_SSTL15.ibs". Macromodels have been 
constructed to reproduce the characteristics given in IBIS file. The construction of such a 
model is not addressed in this part. The instance of the driver is an "Output buffer", its 

symbol can be found in the symbol palette . The macromodel associated to the buffer is 
given by the subcircuit "\examples\ibis\IO_models\SSTL15_II_LR33_v3.sym". The "Output 
buffer" symbol has 4 terminals: power supply references VDD and VSS, a logic input (0-1 V 
signal) and the physical output. The instance of the receiver is an "Input buffer", its symbol 

can be found in the symbol palette . The macromodel associated to the buffer is given by 
the subcircuit "\examples\ibis\IO_models\ SSTL15_IN_Typ_v2 .sym". The "Input buffer" 
symbol has also 4 terminals: power supply references VDD and VSS, the physical input and 
a logic output (0-1 V signal). 

If you double-click on the driver or the receiver, the properties of the symbols can be edited, 
as shown in Figure 3- 45. The field "I/O model" specified the subcircuit file containing the 
macromodel of the I/O buffer. The fields "Resistance", "Inductance", "Capacitance" in the 
"Package" part define the R, L, C stray elements associated to the package input or output 
pin. For "Input buffer" symbol, the properties "High threshold" and "Low threshold" specify the 
logical voltage threshold of the input buffer. 
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Figure 3- 45: Properties of DDR3 driver (left) and receiver (right) (\examples\transient\ 
DDR3_link_400MHz.sch) 

The resistor RT is a termination resistor which is connected to a 0.75 V termination voltage. 
The logic input of the DDR3 driver is driven by a 5 ns periodic square waveform signal. It 
simulates a 400 Mbits/s logic signal with regular '0'-'1' transitions.  In this example, the 
transient profile of the signal delivered by DDR3 driver is simulated, thanks to the command 
line ".tran 0.1n 100n". Three voltage probes have been placed: on the logic input of DDR3 TX 
(node 4), at the output of the microstrip line (node 1) and at the logic output of DDR3 RX 
(node 6). 

In "File > Simulator", select WinSPICE and click on  to generate the netlist and launch the 

simulation. At the end of the simulation, click on the button  to observe the signals. In the 
tab "Parameters", select the three signal to display and click on the button "Add Simu". In the 
tab "Display", you can adjust the scale to zoom on one or two binary periods, as shown in 
Figure 3- 46. The blue and the green curves show the logic signal at the input of DDR3 TX 
and DDR3 RX respectively. There is a delay of nearly 1.6 ns between both signals due to the 
switching time of the SSTL15 output and input buffers and the transmission time through the 
microstrip line. The red curve shows the simulated physical signal at the input of DDR3 RX. 
The waveform of this signal has been affected by the characteristics of the line, the mismatch 
between the line impedance and the termination impedance and the R,L,C stray elements of 
DDR3 TX and DDR3 RX package. A more appropriate representation to analyse the effect of 
the physical transmission to the signal integrity is offered by the eye diagram. 
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Figure 3- 46: Transient simulation of a DDR3 memory link (\examples\transient\ 
DDR3_link_400MHz.sch) 

 

III.7.3 Eye diagram probe 

An eye diagram probe must be placed on the schematic in order to plot an eye diagram 
representation after a transient simulation. The eye diagram probe is found in the symbol 

palette . In this part, the previous schematic will be modified to set-up the simulation for 
eye diagram plotting. 

Save the previous schematic as " 
DDR3_link_400MHz_eye_diagram.sch" with "File > 
Save as". Place an eye diagram probe on the 
schematic. This component has three terminals: 

Á in: connect the signal that you want to analyse 

Á clk: connect the data clock on this terminal 

Á ref: connect the ground 
 

Terminal "in" is connected to the output of the microstrip line. Terminal "ref" is connected to 
the ground. In the previous schematic, no data clock source were present. We must create a 
clock source which is synchronized on the binary signal transmitted by DDR3 TX. This 
source must produce a rising transition at each binary transition of the signal connected on 
terminal "in". Thus, a voltage source called "V_data_clock" is inserted on the schematic, with 
the properties shown below. The period of the data clock source is set to the binary period, 
i.e. 2.5 ns in order to be synchronous with the transmitted binary signal (400 Mbits/s). A 
delay of 1.6 ns (field "TD") is introduced to compensate the delay between the signal 
transmitted through the microstrip line and the data clock. 
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Figure 3- 47: Prepare the simulation for eye diagram plotting - set the data clock source 
(\examples\transient\ DDR3_link_400MHz_eye_diagram.sch) 

 

Only one active eye diagram probe should be placed on the schematic. The other voltage 
probes can remain active. The schematic should look like the diagram shown in Figure 3- 49. 

III.7.4 PRBS source 

The model is not completely achieved to perform an eye diagram analysis. The source 
connected to the input of DDR3 TX produces a regular logic sequence '010101é". As 
explained before, a properly constructed eye diagram should contain every possible bit 
sequence. A commonly used source for this purpose is called Pseudo-Random Binary 
Sequence generator. It can produce a synchronous logic signal whose logic state change 
randomly at each clock period. Such a source can be constructed in IC-EMC by generating a 
Piece-Wise Linear (PWL) signal. Click on the menu "Tools > PWL Source Generator" and 
select "Random bit stream (PRBS)" in the field "Select the mathematical operation". Set the 
parameters shown in Figure 3- 48.  

 

Figure 3- 48: Set a PRBS source synchronized at 400 MHz (\examples\transient\pwl_PRBS_DDR3.txt 
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The frequency is set to 400 MHz, i.e. the binary period is 2.5 ns. The step is 0.1 ns and 
10000 samples will be generated, so that the total duration of the PWL signal will be 1 µs, 
corresponding to 400 transmitted bits. Click on the button "Generate PWL" to see an 
overview of the signal. Click on the button "Save PWL" to save the PWL file in the text file 
"pwl_PRBS_DDR3.txt".  

On the schematic, double-click on the voltage source Vbinary to edit its properties. Select 
"Piece-Wise Linear" type and select the file " pwl_PRBS_DDR3.txt" in the field "Described in 
file". Finally, change the command line ".tran 0.1n 100 n" to ".tran 0.1n 1000n" to set a longer 
simulation file. The longer the simulation is, the larger the number of transmitted bits and the 
better the eye diagram plot. 

 

Figure 3- 49: Schematic simulation for eye diagram plotting of the DDR3 memory link 
(\examples\transient\ DDR3_link_400MHz_eye_diagram.sch) 

III.7.5 Plot the eye diagram 

In "File > Simulator", select WinSPICE and click on  to generate the netlist and launch the 
simulation. At the end of the simulation, click on the menu "Tools > Eye Diagram" to open the 
eye diagram window. Select the signal to analyse in the combo box "Input signal", here v(1). 

The, click on the button  to plot the eye diagram. The result is presented in Figure 3- 
50. As indicated in the message bar in the bottom of the window, the input signal has been 
cut in 397 sections which have been superimposed to plot the eye diagram. 

The field "Clock Freq (MHz)" indicates the data clock frequency extracted by the tool from 
transient simulation result. The value can be slightly different of the specified value in the 
source V_data_clock. To reduce this gap, reduce the PWL source step and transient 
simulation step. However, the eye diagram plot should not change significantly.  
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Figure 3- 50: Eye diagram of the DDR3 memory link (\examples\transient\ 
DDR3_link_400MHz_eye_diagram.sch) 

The result shows an eye diagram with adequate horizontal and vertical apertures. However, 
this model does not take into account the power delivery network of both driver and receiver, 
which introduces non negligible inductance along the power supply network. Moreover, in a 
real DDR3 memory link, several data lines switch simultaneously which may introduce power 
significant power supply voltage drops. Moreover, crosstalk between adjacent lines could 
introduce additional noise. All these effects may degrade the eye diagram apertures. 

In order to compare design changes on signal integrity, quantitative criteria must be defined, 
as those defined in III.7.1. When the eye diagram is extracted, eleven signal integrity criteria 
are evaluated and displayed in the table "Signal integrity indicators", in the bottom right part 
of the eye diagram window. For most of the criteria, average, standard deviation, minimum 
and maximum values are determined. For example, in this example, the vertical opening of 
the eye diagram (eye height) is evaluated to 1.183 V centered around nearly 0.75 V. The 
SNR is evaluated to 27.63. The amplitude distortion is not too large to introduce significant 
bit error risk. The horizontal opening of the eye (eye width) is evaluated to 2.09 ns or 0.83 UI. 
UI stands for 'Unit Interval', i.e. a time interval equal to the binary period. The peak-to-peak 
value of the jitter is about 286 ns, i.e. 11 % of the binary period. 

 

 

III.8 Near-field analysis 

Over the last years, the near field scanner has become a popular tool to diagnose EMC 
problems at PCB and IC levels. The measurement of the magnetic and electric fields near 
the surface of IC or PCB gives access to the current and charge surface distribution 
respectively, which can be helpful to understand the origin of EMC issues (conducted 
emission, crosstalk, radiated emission). Moreover, the measurement of the near-field 
emission offers a method to extrapolate the far-field emission.  

In this short case study, a complex signal is generated and its characteristics are studied. An 
example based on a power amplifier (PA) for a 3rd generation mobile platform is used. The 
near-field scan measurement results are plotted with IC-EMC. Then, a near-field emission 
model is derived from the ICEM model of the PA. Finally, its near-field emission is simulated 
and compared with measurements.   
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III.8.1 Near-field scan measurement principles 

The measurement of the electric or magnetic components in the near field is interesting for 
EMC of ICs because it helps to locate transient current circulation as well as strong voltage 
variations. Indeed, at very short distance from a conductor, it is possible to separate the 
respective contributions of each part of this conductor. As distance from the conductor 
increases, all of these contributions superimpose and only the global radiation from the 
conductor can be measured. 

A near field scan measurement method is described in the international standard IEC 61967-
3 [IEC61-3]. The typical measurement set-up with a near-field scanner is presented in Figure 
3- 51. A miniature magnetic or electric antenna, called near-field probe, is placed very close 
to the device under test to measure the electric and/or magnetic field in the reactive or near-
field area. The voltage induced across the near-field probe by the incoming field is measured 
by a receiver. A spectrum analyzer is usually connected to measure the amplitude of the 
induced voltage. The near-field probe is fixed to the arm of a 3D positioning system and its 
position is moved and set accurately to one measurement point, following a predefined 
pattern in the scan surface. For each position, the receiver captures the voltage induced 
across the probe (the amplitude and/or the phase of the spectrum at several frequencies, or 
the time domain waveform). This operation is repeated above each point of the predefined 
pattern. At the end of the scan surface sweeping, a near-field map is reconstructed by a 
post-processing tool. The map highlights some ñhot spotsò, i.e. areas where the incoming 
field is large. 
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Figure 3- 51: Principle of the measurement of near-field scan emission of an IC 

 

The near-field probes act as a transducer of electric or magnetic field into a voltage. They 
have various forms, but basically  they consist of either small magnetic or short electric 
dipoles which integrate the incoming field over their surface. Ideally, the probe size should be 
infinitesimal in order to provide a local measurement and prevent disturbance from the 
incoming field. The probe should be calibrated prior near-field measurements to convert the 
measuring voltage into incoming electric or magnetic field. 

III.8.2 Plotting near-field scan measurement with IC-EMC 

The circuit studied in this part is a power amplifier (PA) used for 3rd generation or UMTS 
mobile platform. The PA amplifies the signals from the transceiver to the antenna. It is able to 
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send RF modulated signals in the frequency range 1920-1980 MHz with a maximum power 
of 0.25 W or 24 dBm. Three different near-field scan tests were performed above the PA with  
magnetic field probes to measure the horizontal Hx and Hy components and the vertical Hz 
component of the magnetic field. They consist in simple circular loop made at the end of a 
semi-rigid coaxial cable. The scan were performed at an altitude of 1.1 mm above the PA 
surface. The measurement area is 6.2 x 6.4 mm with X and Y steps of 0.2 mm. During these 
measurements, the center frequency of the UMTS power amplifier was fixed to 1950 MHz. 
More details about this case study can be found in [App_PA] and [Dup09]. 

Near-field scan measurement results were exported in a standard XML exchange file 
[IECTR61]. The format of this file is described in Part VI. Click on the menu "EMC > Near-

field scan" or on the button  to open the "Near-field scan" interface. A window opens, with 
a black screen on the right for the display of measured or simulated near-field scan, and a 
series of tabs and buttons for simulation configurations, display options and measurement 

import. Click on the button  to import a measurement file. In this example, three 
measurement files are provided: 

Á \Scan_Hx_PA_1950_1_5mm\Scan_Hx_PA_1950_1_5mm_PA.xml: measurement of the x 

component of the magnetic field  

Á \Scan_Hy_PA_1950_1_5mm\Scan_Hy_PA_1950_1_5mm_PA.xml: measurement of the y 

component of the magnetic field at 1950 MHz 

Á \Scan_Hz_PA_1950_1_8mm\Scan_Hz_PA_1950_1_8mm_PA.xml: measurement of the z 

component of the magnetic field at 1950 MHz 

 

Select the file Scan_Hz_PA_1950_1_8mm_PA.xm and the results shown in Figure 3- 52 is 
displayed. It shows the distribution of the vertical component of the magnetic field (Hz) 
produced above the PA at 1950 MHz. This distribution is superimposed to a picture of the 
device under test. The color scale gives the amplitude of the magnetic field. The maximum 
magnetic field reaches up to -32 dBA/m. As indicated by the red mark. The analysis of this 
measurement results shows clearly that the magnetic emission is above the power output 
and power supply pins of the PA [Dup09]. The color scale, the zoom and the alignment of the 
measured scan on the background picture can be set in the tab "Display".  
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Figure 3- 52: Example of near-field scan with IC-EMC (\case_study\pa_3G\ 
Scan_Hx_PA_1950_1_5mm\Scan_Hz_PA_1950_1_8mm_PA.xml) 

 

The same screen is shared for simulation result display. Once the measurement result has 
been imported, click on the button "Meas. scan" in the tab "Parameters" to display 
measurement results. The information about the imported measurement file are summarized 
in the tab "Information". 

III.8.3 Simulating near-field emission with IC-EMC 

III.8.3.1 Principle of the simulation 

Various methods exist to compute EM fields produced by conductors. Three-dimensional full 
wave simulators are based on numerical methods that can adapt to any conductor geometry. 
They are the most accurate but unfortunately the most time consuming methods. In contrast, 
methods based on analytical formulations or geometry simplifications are very fast but they 
are limited only to simple geometries. The choice of an electromagnetic field solving method 
depends on the required accuracy level and the maximum simulation time. For example, at 
an early design phase, exact models cannot be available and simple calculations are often 
required to set some design budget. Full wave simulations can only be performed at design 
end for optimization purposes.  

Co-simulation tools including electrical and EM simulators are required to simulate both non-
linear responses and radiation of ICs. Figure 3- 53 describes the general simulation flow of 
this type of tool. EM fields are extracted from voltages and currents crossing metal 
interconnects of ICs. At IC level, package leads and bonding wires are the largest 
interconnects. As most of electromagnetic solvers are based on frequency domain methods, 
FFT algorithm is required.  
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Figure 3- 53: General simulation flow for IC radiated emission prediction 

IC-EMC proposes a co-simulation method to estimate near field emission from ICs. Circuit 
simulations are handled by WinSPICE, Ngspice or LTSPICE. An EM simulator is offered by 
IC-EMC to extract electrical and magnetic field at any point in (X,Y,Z) from currents and 
voltages computed by SPICE simulation, and by means of some approximations concerning 
the package and electromagnetic field formulations. The general flow used to achieve a 
comparison between near-field measurement and simulated magnetic field emission is 
proposed in Figure 3- 54. The main assumption is that package leads used for supply and 
output signals are the main radiating elements.  
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Figure 3- 54: Flow for comparing predicted and simulated magnetic field scans 
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At package level, leads and bonding wires are considered as the main radiated elements so 
that the package model is very important for the prediction of near field scan. IC-EMC uses 
the current computed by WinSPICE, Ngspice or LTSPICE to compute the resulting radiated 
emission. A link must be made between the current and the radiated elements. Two methods 
are used to model the radiating elements. In the first method, as the package leads and 
bonding wires are mainly inductive at low frequency, this link is made with the inductances 
which model package leads. These inductances called ñradiating inductancesò are classical 
inductances through which transient current flows, with attached geometrical coordinates. 
Simple geometrical models are considered for the package. Leads and bonding wires are 
modeled by one or several straight wires (Figure 3- 55). 
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Figure 3- 55: Principles of simplified package model reconstruction and link to the electrical model 
through ñradiatingò inductances 

 

This method assumes that the transient current circulates along electrically short 
interconnect, so that the ñcapacitive effectò of package interconnects can be neglected (i.e. 
charge storage). This assumption is valid until package interconnect length is less than ɚ/10 
(quasi-static approximation). When package interconnects become electrically long, taking 
into account the ñcapacitive effectò of package interconnect become essential, especially for 
the prediction of electric field distribution in near-field. Indeed, a large part of electric field in 
near-field area is linked to charge storage, which cannot be modeled by inductance. 

A more realistic electrical modeling approach consists in modeling interconnect by distributed 
RLC cells. IC-EMC proposes a second method for a more accurate prediction of near-field 
emission based on a component called ñRadiated Interconnectò, available in the Symbol 

Palette . They are not described here. More information can be found in [App_NF]. 

The geometrical information of ñradiating inductancesò can be entered manually or given by 
IBIS file (see part III.5). The package and die size information text are added in the [package 
model] section of the IBIS file. The comment is mandatory to avoid parsing errors with 
conventional IBIS readers. However, IC-EMC can locate ó|pack_ô and ó|ic_ô keywords and get 
the relevant information. The 2D and 3D views of the package may then be reconstructed, as 
shown in Figure 3- 35.  
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III.8.3.2 Near-field Prediction Steps 

Assuming that the package bonding wires and leads are the main radiating elements, their 
associated current must be computed, prior to magnetic field reconstruction (and also charge 
storage for electric field reconstruction). Therefore, the simulation steps are as follows: 

 

1. The IBIS file is loaded, from which the pin list, package dimension and type are 
extracted 

2. From the IBIS information, the package is reconstructed. Each lead is assigned a 
position in space. 

3. Selected inductances (mainly supply and IO inductances) are assigned to the 
corresponding space coordinates (or select radiated interconnects). 

4. The analog time-domain simulation is performed to determine all the currents flowing 
in each declared package inductances.  

5. The Fourier transform applied for each of these currents gives the magnitude I(f) for a 
frequency chosen for scanning.  

6. Theoretical formulations are used to compute the sum of H and E contributions at 
each location of the space [x,y,z] in frequency domain.  

7. A post-processing displays the resulting magnetic field at the user-defined distance 
above the ground plane. 

 

III.8.3.3 Formulations used to compute near-field emission 

Formulations used by IC-EMC to compute electric and magnetic fields radiated by a package 
are based on the thin wire approximation. They are computed in frequency domain. Each 
lead of a package is meshed in small elementary thin wire crossed by a current constant 
over all the lead. This assumption remain valid until the lead length is negligible in 
comparison to the wavelength ɚ (length < ɚ/10). The electric and magnetic fields generated 
by of each elementary wire are calculated from the equations reported in Figure 3- 56. 
Parameters are the length of the current element l, the current amplitude I0 in the element 

(A), and w=2p.f (rad/s). The magnetic current at the observation point is the sum (in complex 
domain) of all elementary currents flowing in all leads. 
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Figure 3- 56: Electric and magnetic field formulations with the thin wire approximation  

If the package lead is longer than ɚ/10, the package is split into elementary dipoles as shown 
in Figure 3- 57. The electric and magnetic current at the observation point are the sum (in 
complex domain) of all elementary currents flowing in the package leads. 
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Figure 3- 57: Decomposition of package leads in elementary thin wires and contribution to the total 
electric and magnetic fields 

 

III.8.4 Near-Field Prediction 

In this part, the different steps to load the model, run the simulation and compute the near-
field emission are presented. 

III.8.4.1 Load the simulation model 

The model of the PA for its near-field simulation is given in the file " \case_study\pa_3g\ 
PA_scan_V_add_vertical_1950MHz.sch". The electrical schematic diagram is presented in 
Figure 3- 58. It includes the supply network, the PDN of the PA, the pre-amplifier stage and 
the power stage itself, connected to a 50 ɋ through a transmission line. Note that the PA 
itself is mainly a current source. 
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Pre-amplifier 
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Figure 3- 58: The schematic diagram of Prometheus used for near-field scan prediction 
(case_study\pa_3G\PA_scan_V_8_1950MHz.sch) 

 

The position of the package leads are deduced from the IBIS file. Normally, the IBIS file of 
the PA is imported automatically when the schematic is opened thanks to the command line 
".ibs .ibis prometheus_mmm6030_v2.ibs". If a warning message indicates that the IBIS file is 
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not found, you can import it manually with the command "File > Load Ibis file" or with the 

button  in the command bar. Figure 3- 59 shows a 3D reconstruction of the PA package 
visible in the IBIS interface (see part III.5.3.3). The position of the different pins can be 
highlighted. 

 

Figure 3- 59: 3D view of the PA package (\case_study\pa_3G\ prometheus_mmm6030_v2.ibs) 

 

Figure 3- 60 details how the package lead inductances are assigned physical coordinates to 
enable the IC-EMC simulator to compute the radiated field. You can define it manually by 
typing the coordinates in the "Xstart", "Ystart", "Xstop", "Ystop", "Zstart" and "Zstop", or using 
IBIS information by selecting a pin in the list "Select pin from the IBIS pin list". The Z 
coordinate indicates the altitude of the dipoles above a plane reference which is supposed to 
be the surface of the PCB on which the circuit is mounted. 

 

Coordinate in z direction 

 

Figure 3- 60: The schematic diagram of Prometheus used for near-field scan prediction 
(Scan_Hx_PA_1950_1_5mm\PA_scan_V_add_vertical_1950MHz.sch) 

 

III.8.4.2 Preparing SPICE simulation 

The near-field simulation is based on the transient waveform of currents and voltages across 
radiated interconnects. A transient simulation is configured with the command line " .TRAN 
0.1N 100N". It can be inserted according one of the two following methods: 

Á click on button or in the "Edit > Text" menu, directly type the SPICE analysis command  

Á in the Insert menu, click on ñInsert analysis lineò. An interface dedicated to the configuration 

of the SPICE simulation is opened and the analysis line is automatically inserted on the 

schematic with the correct syntax. 
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Another command line is inserted on the schematic: " . scan 0.5e-3 1e8 2e8 2 3.5e-3 1.2e-3". 
It contains directive for the near-field simulation tool. The parameters of the command line 
will be described in part III.8.4.4. 

 

III.8.4.3 Run SPICE simulation 

Select WinSPICE as simulator in "File > Simulator". In the menu "File > Simulator > 
Configurations", select "Interactive mode" to launch SPICE simulation automatically after the 

SPICE netlist generation . 

III.8.4.4 Near-field simulation 

Open the "Near-field scan" interface by clicking on the button  or in the menu "EMC > Near 
field scan". The window shown in Figure 3- 61 opens. In the right part, the simulation 
parameters and the display options can be configured. In the left part, the position of the 
radiatng dipoles or interconnects and the simulated or measured E or H field are plotted in a 
X-Y surface at a given altitude. Different components of the fields can be plotted (x, y, z, 
tangential, total), either the amplitude (in dBV/m or dBA/m) or the phase (in degree). When 
the window is opened, no simulation or measurement results have been loaded, so the 
screen is black.  

The default opened tab is "Parameters" for the configuration of the simulation and the 
selection of frequency and field component to display. Clicking on the button "Far field" 
computes the far-field emission in two vertical planes. The tab "Display" is dedicated for the 
control of measurement or simulation result plot (zoom, scale color, scale adjustement...). In 
the tab Dipole, the amplitudes of the excitation currents of the radiating dipoles at the 
simulation frequency are listed. In the tab "Save", several options to save simulated scans in 
a XML file are proposed. 2D graph of the near-field emission can be displayed if the button 
"2D graph" is clicked. 

The simulation options in the tab "Parameters" are preconfigured because of the command 
line ".scan 0.5e-3 1e8 2e8 2 3.5e-3 1.2e-3" placed in the schematic diagram. The format of 
this command line is: 

.scan  step sta rt_freq stop_ freq freq _nb scan_ alt dipole_ alt  

where: 

Á step is the scan step. In this example, the field is computed with a spatial resolution of 0.5 mm. 

Á start_freq, stop_freq and freq_nb define the frequency sweep between start_freq and stop_freq. 

freq_nb defines the number of frequency points of the simulation 

Á scan_alt defines the altitude of the scan plane, i.e. the distance above the reference plane 

where the field values are computed 

Á dipole_alt is the default altitude of the radiated dipoles and interconnects if it is not defined. 

We remind here that the reference plane is the surface of the PCB on which the circuit is 
mounted. Depending on the selection of the option "Ground plane at z = 0", a perfect ground 
plane can fill the reference plane. 
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Figure 3- 61: Near-field scan interface 
(Scan_Hx_PA_1950_1_5mm\PA_scan_V_add_vertical_1950MHz.sch) 

 

Before launching the computation, verify the parameters of the simulation: frequencies, scan 

altitude, ground plane, scan step, position of dipoles. Click on the button  to launch 
the computation. It can take several minutes depending on the number of dipoles and 
frequency points. 

At the end of the computation, the total magnetic field (Htot in the combo box "Display") at F 
= 1920 MHz is plotted. In the tab "Display, the scale and the position of the scan are can be 
adjusted. Figure 3- 62 presents the vertical component of the magnetic field Hz simulated at 
1920 MHz. 
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Figure 3- 62: Simulation of the vertical components of the magnetic field Hz simulated at 1920 MHz 
(Scan_Hx_PA_1950_1_5mm\PA_scan_V_add_vertical_1950MHz.sch) 

 

A comparison between measurements and simulations is presented in Figure 3- 63. The 
differences are summarized in Table 3- 9.  

 

Hx Hy Hz 

 (dBA/m) Measure 

Simulation with vertical current dipoles  

Figure 3- 63: Comparison between measurements and simulations of the three components of the 
magnetic field (Scan_Hx_PA_1950_1_5mm\PA_scan_V_add_vertical_1950MHz.sch) 

 

Measurement Hx Hy Hz 

-41 dBA/m -37 dBA/m -32 dBA/m 

Simulation Hx Hy Hz 



 III. Working with IC-EMC 

 

87 

 

-40 dBA/m -37 dBA/m -38 dBA/m 

Table 3- 9: Comparison between measured and simulated peak magnetic field  

 

 

 

III.9 Interconnect modeling 

Modeling Interconnect at package, PCB or system level is a very important task to predict 
EMC issues. IC-EMC proposes several tools to evaluate stray R, L, C parameters and build 
equivalent electrical models of basic types of electronic interconnects, at different levels: 

Á PCB traces and planes 

Á package 

Á cables 

The following sections presents these tools through simple examples. 

 

III.9.1 Modeling a microstrip line designed on a FR4 PCB 

In this part, a SPICE compatible model of a microstrip line will be constructed in order to 
simulate S parameters from its terminals. The geometry and the parameters of the line are 
described in Figure 3- 64. The final model is available in the file 
"\examples\basic\microstrip_S_parameters.sch". The following parts will guide you to build 
the model step-by-step. 

Reference
plane

Trace

Dielectricsubstrate

h

W

rʁ , tan d
L

 

Figure 3- 64: Geometry of the modeled microstrip line 

The microstrip line is designed on a 0.2 mm thick FR4 substrate. The relative permittivity of 
the substrate is Ůr = 4.5 and its loss tangent tan d = 0.02. The trace is made of 35 µm thick 
copper. The trace is 50 mm long and its width must be adjusted to match its characteristic 
impedance Z0 to 50 ɋ. The model must be valid up to 20 GHz. 

III.9.1.1 Open the tool "Interconnect Parameters" 

The tool "Interconnect Parameters" is dedicated to the modeling of PCB interconnects with 
basic cross-section (e.g. microstrip line, coplanar waveguide, edge-coupled microstrip line, 
viaé) and the construction of equivalent electrical model. Click on the menu "Tools > 
Interconnect Parameters" to launch this tool. The following window appears, with microstrip 
line as default configuration.  
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Figure 3- 65: Description of "Tools > Interconnect Parameters" 

In this tool, the cross-section and the material are supposed to be homogeneous. Modeling 
an interconnect requires the definition of cross-section geometry, the interconnect length, the 
material electrical properties (trace metal and dielectric insulator) and a maximum validity 
frequency (some parameters are frequency dependent). Once these parameters have been 
defined, the electrical characteristics of the interconnect can be extracted from closed-form 
expressions or numerical computations, such as: 

Á per-unit-length (pul) electrical parameters r, l, c and g 

Á characteristic impedance, odd and even impedance (for three conductor interconnects) 

Á wave velocity and propagation delay 

Á skin depth  

Finally, SPICE compatible models can be derived from these computed elements.  

 

III.9.1.2 Electrical parameter extraction 

The microstrip line must be 50 ɋ matched. In practical PCB design, the trace's width W is 
adjusted to set the characteristic impedance. In Interconnect Parameters, fill the geometrical 
dimensions and the material properties according to the description given in III.9.1. Start with 

a default value for the width, equal to 0.1 mm. Then, click on the button  to 
compute the electrical characteristics of the line, which appear on the right side of the 
screen. In this default configuration, the characteristic impedance is given by the term "Z0" 
and is equal to 86 ɋ.  

Increase the width to reduce the characteristic impedance. It should be equal to 50 ɋ when 
the width is set to 0.347 mm, as shown in Figure 3- 66. 
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Figure 3- 66: Adjustment of the trace's width to set the characteristic impedance of the microstrip line 

 

The pul r,l,c,g parameters of the line are also computed. The pul inductance and inductance 
of the lines are given by the terms "L11" and "C11". We can verify that the characteristic 
impedance is equal to:  

11

11
0

C

L
Z =        Equ. III-8 

The pul resistance and conductance are actually frequency dependent (even if L11 is also 
slightly frequency dependent due to skin effect). The term "Rdc" gives the pul resistance at 
low frequency, when the skin effect is negligible i.e. when the lateral dimensions of the line 
are smaller than the skin depth ŭ. For example, at 20 GHz, the skin depth is 0.5 µm so that 
this effect cannot be neglected. The pul resistance tends to increase with frequency 
according to a square-root relation. The term "Rac" gives the actual pul resistance at the 
maximum validity frequency of the model (here 20 GHz). The frequency evolution of the skin 

depth and Rac can be saved in a .z file by clicking on the button . 

Similarly, the term "G" gives the conductance associated to dielectric substrate losses at the 
maximum validity frequency of the model. 

 

 

III.9.1.3 Extraction of a SPICE compatible model 

From the pul parameters, a SPICE compatible model can be derived. A short section of a 
transmission line can be modeled by a lumped RLCG model. The model remains valid as 
long as the length of the section is less than ɚ/20 or ɚ/10, where ɚ is the wavelength 
associated with the highest frequency of the signal conducted along the line. Thus, the full 
model of the line consists of a distribution of this RLCG network.  

In Figure 3- 66, the last line of the right part of the screen  gives the 
maximum length of a line section which can be modeled by a single RLCG network up to 20 
GHz. As the microstrip line is 50 mm long, 50/0.82 = 61 RLCG networks are required to 
model the microstrip line up to 20 GHz. 
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Before generating the SPICE model, several options may be chosen. They are visible on the 
lower left part of the this screen ("SPICE Model Generation"): 

Á Include losses: if the option is not selected, only the DC resistance of the line is taken into 

account, the skin effect and dielectric losses are neglected. This assumption is usually valid 

with practical PCB traces up to several hundreds of MHz. Above several GHz, losses should 

be taken into account, especially for signal integrity simulation 

Á Near-field analysis: if this option is selected, geometrical coordinates are assigned to each 

RLCG network of the model in order to simulate the electric and magnetic field emission 

produced by currents circulating along the line (refer to III.8). 

Á Create subcircuit: if this option is selected, the SPICE model is saved in a subcircuit. 

Otherwise, RLCG networks are placed directly on the schematic. 

For the studied microstrip line, check "Include losses" to include frequency dependent losses 
in the model, and  leave "Near-field analysis" unchecked. Initially, we let the option "Create 

subcricuit" unchecked. Click on the button  to generate automatically the 
equivalent model of the line. Then click on the button OK to close the window. A large 
number of RLCG networks have been placed on the schematic, as shown in . Click on the 

button  to see all the RLCG networks. 62 RLCG networks have been placed. 

62 RLCG networks placedon the schematic

Zoom on the first RLCG networks

 

Figure 3- 67: Electrical model of the microstrip line valid up to 20 GHz 

The advantage of this model display is that the content of the model is visible explicitly. 
However, at high frequency, the number of RLCG cells may become large sufficiently to 
make it unreadable. Therefore, it is better to select the option ""Create subcircuit".  

Remove all the RLCG networks placed on the schematic with the symbol . Then open the 
"Interconnect Parameters" tool and fill all the fields as in Figure 3- 66. Check the option 
"Create subcircuit". A field "Save subcircuit as:" appears to specify the name of the subcircuit 

file. Click on the button  to select the directory and the file name. The subcircuit is saved in 
.sym file. The microstrip line model has been saved in 

"\example\basic\microstrip_20GHz.sym". Finally, click on the button  to save the 
SPICE model in the .sym file. This time, no model is placed automatically on the schematic. 
Click on OK to close the window. 

 

 


